DNS option not being pushed on 2.1.3.111 client

Post Reply
choodee
OpenVpn Newbie
Posts: 5
Joined: Fri Oct 13, 2017 2:09 am

DNS option not being pushed on 2.1.3.111 client

Post by choodee » Fri Oct 13, 2017 2:22 am

Hello,

I am currently running Azure OpenVPN appliance v2.1.12 with OpenVPN Connect 2.1.3.111 on windows 10, and I'm having issues resolving my internal computers. Push DNS is configured and shows up on the client's logs but it doesn't show up on the client when I run ipconfig /all. However, when I use an older openvpn connect client 2.0.18.202, everything works fine, including resolving my internal computers. Is there any reason why when I use the client that comes with the Access Server appliance it fails, yet when I use an older client it's ok?

Any help will be appreciated.

thanks

novaflash
OpenVPN Expert
Posts: 493
Joined: Fri Apr 13, 2012 8:43 pm

Re: DNS option not being pushed on 2.1.3.111 client

Post by novaflash » Fri Oct 13, 2017 7:02 am

Empty out the fields "DNS Resolution Zones" and "DNS Default Suffix" and it'll show up in ipconfig.

choodee
OpenVpn Newbie
Posts: 5
Joined: Fri Oct 13, 2017 2:09 am

Re: DNS option not being pushed on 2.1.3.111 client

Post by choodee » Fri Oct 13, 2017 8:25 am

Thank you. That seemed to have fixed it, now my internal DNS servers are showing up. However, I need DNS Default Suffix so I that I can resolve my internal servers using the right FQDN. Why would filling out these fields prevent DNS-options from working?

novaflash
OpenVPN Expert
Posts: 493
Joined: Fri Apr 13, 2012 8:43 pm

Re: DNS option not being pushed on 2.1.3.111 client

Post by novaflash » Fri Oct 13, 2017 8:32 am

DNS Default Suffix is probably fine for you to use then.

DNS Resolution Zones is specifically designed NOT to implement the DNS server globally. It is designed to implement it in NRPT only. Therefore it won't be visible in ipconfig output.

choodee
OpenVpn Newbie
Posts: 5
Joined: Fri Oct 13, 2017 2:09 am

Re: DNS option not being pushed on 2.1.3.111 client

Post by choodee » Fri Oct 13, 2017 9:03 am

Ok I filled DNS Default Suffix but left DNS Resolution Zones empty. However, even though my internal DNS servers are showing up, resolution of internal hostnames still fail due to not having the right FQDN. I just scoured the openvpn forums and found this thread:

viewtopic.php?t=21980

It seems like the same issue as our AS server used to work perfectly (2.0.x) prior to moving to AS 2.1.12 with 2.1.3.111 client. Has this issue been resolved? or should I revert to the old server as well as client for all of our users?

thanks.

choodee
OpenVpn Newbie
Posts: 5
Joined: Fri Oct 13, 2017 2:09 am

Re: DNS option not being pushed on 2.1.3.111 client

Post by choodee » Mon Oct 16, 2017 3:55 am

Hi there, does anyone else have an idea if this problem has been fixed? Or perhaps point me to another solution?

Thanks

ewitt
OpenVpn Newbie
Posts: 1
Joined: Mon Oct 16, 2017 2:59 pm

Re: DNS option not being pushed on 2.1.3.111 client

Post by ewitt » Mon Oct 16, 2017 2:59 pm

choodee,

Did you ever find a solution for this problem? We are having the same issue.

spankycarbowski
OpenVpn Newbie
Posts: 1
Joined: Thu Oct 19, 2017 2:45 pm

Re: DNS option not being pushed on 2.1.3.111 client

Post by spankycarbowski » Thu Oct 19, 2017 2:50 pm

I have the exact same issue. Any resolution would be good to know!
I've also found some other strange behaviour -
domain computers are fine.
Non-domain computers i need to appends the dns suffix manually. (same with android clients.)

elliot
OpenVpn Newbie
Posts: 8
Joined: Mon Sep 24, 2012 8:28 pm

Re: DNS option not being pushed on 2.1.3.111 client

Post by elliot » Sat Oct 28, 2017 7:58 am

This is an extremely frustrating issue.

I have raised a support ticket and have been told that they are fully aware of DNS-related issues with Access Server in its current form, and that they're working to resolve it.

In the meantime though, it's causing us a lot of headaches for client users.

Any further updates or work-arounds from the community would be welcome.

Regards,

Elliot

choodee
OpenVpn Newbie
Posts: 5
Joined: Fri Oct 13, 2017 2:09 am

Re: DNS option not being pushed on 2.1.3.111 client

Post by choodee » Fri Nov 17, 2017 7:50 pm

No this has not been resolved and OpenVPN has been quiet since I posted Elliot's thread.

too bad.

Post Reply