ovpn-init failure

Post Reply
carmonj
OpenVPN User
Posts: 10
Joined: Wed Aug 02, 2017 5:03 pm

ovpn-init failure

Post by carmonj » Wed Aug 02, 2017 5:06 pm

After running ovpn-init I am receiving the error "Could not initialize sa"

I installed openvpc-as.

My system is running fedora 26 as a server.
Any thoughts? I don't know where to begin.

novaflash
I should be on the dev team.
Posts: 821
Joined: Fri Apr 13, 2012 8:43 pm

Re: ovpn-init failure

Post by novaflash » Wed Aug 02, 2017 6:08 pm

I think it's not compatible with that version of fedora. You can try running an install on another supported OS, and then running ovpn-init on that system, and then copying the resulting files from the /usr/local/openvpn_as/etc/db/ folder to this installation and restart the Access Server service, to try to get around the initialization problem.

carmonj
OpenVPN User
Posts: 10
Joined: Wed Aug 02, 2017 5:03 pm

Re: ovpn-init failure

Post by carmonj » Tue Aug 15, 2017 8:34 pm

I was able to get it running. The issue turned out to be a missing 64 bit library. I'll have to dig though and find out specifically what one.

mayday
OpenVpn Newbie
Posts: 1
Joined: Fri Jan 11, 2019 6:07 am

Re: ovpn-init failure

Post by mayday » Fri Jan 11, 2019 6:11 am

If anyone is running in this issue sa init actually depends on the internal sqlite3 binary.

On Amazon Linux 2 it was missing the libncurses.so.5 and libtinfo.so.5 provided by ncurses-compat-libs.
You can find the missing libs by using ldd sqlite3

Post Reply