Which candidate AS for Ubuntu 15.10 Wily?

bulgin
OpenVpn Newbie
Posts: 4
Joined: Sat Jul 15, 2017 1:40 am

Which candidate AS for Ubuntu 15.10 Wily?

Postby bulgin » Sat Jul 15, 2017 2:27 pm

I see several version candidates for running Access Server on Ubuntu - one for Ubuntu 14 and one for Ubuntu 16 but none listed for 15.

So what's the proper choice?

novaflash
OpenVPN Expert
Posts: 409
Joined: Fri Apr 13, 2012 8:43 pm

Re: Which candidate AS for Ubuntu 15.10 Wily?

Postby novaflash » Sun Jul 23, 2017 12:14 pm

We have chosen to only build for the Long Term Support versions of Ubuntu. Meaning, versions 12.04 LTS, 14.04 LTS, and 16.04 LTS. The uneven numbers are sort of short term releases that build up to a new long term support version. If you are on Ubuntu 15 now, I suggest you upgrade to 16 LTS.

If you want to stay on Ubuntu 15 then you can try the one for Ubuntu 14 or the one for Ubuntu 16, and see if it works for you. It probably will.

chilinux
OpenVPN User
Posts: 13
Joined: Thu Mar 28, 2013 8:31 am

Re: Which candidate AS for Ubuntu 15.10 Wily?

Postby chilinux » Wed Jul 26, 2017 11:40 pm

OpenVPN AS is packaged to be mostly self contained (it supplies it's own python and other resources independent of the distribution). This should make it easier to use it on a slightly different Ubuntu version than what it claims to be published for.

After installing, you might want to run the following to look for places where a different library version is expected:
export LD_LIBRARY_PATH="/usr/local/openvpn_as/lib"
ldd /usr/local/openvpn_as/bin/* \
/usr/local/openvpn_as/sbin/* \
| grep "not found"

However, I would also recommend upgrading to an LTS release for running security related services.


Return to “Access Server”

Who is online

Users browsing this forum: No registered users and 4 guests