Multiple Sessions per user issue

Post Reply
HintonIT
OpenVpn Newbie
Posts: 7
Joined: Wed Dec 04, 2013 10:46 pm

Multiple Sessions per user issue

Post by HintonIT » Wed Jun 07, 2017 1:27 pm

I am running Access Server appliance 2.0.12. I have configured it to run with LDAP configuration, and everything is working fine except for Multiple sessions.
I have a service company that has multiple support staff, and sometimes a couple of them are connected in working on different issues. Rather than setup separate accounts for each user I have a single account for them. I am not running static IP's for that user (or any) and I have the Multiple Sessions per user setting checked, but it still bumps users off when a new connection is made. What other settings do I have to worry about to make this work?
I'd post screen shots....
User IP addressing - Dynamic
User Addressing method - NAT
VPN mode - Layer 3

novaflash
I should be on the dev team.
Posts: 720
Joined: Fri Apr 13, 2012 8:43 pm

Re: Multiple Sessions per user issue

Post by novaflash » Wed Jun 07, 2017 1:30 pm

Pretty much any setting on a user makes it impossible to do multiple concurrent connections on a user account. Not just static IP. That is just mentioned as an example.

HintonIT
OpenVpn Newbie
Posts: 7
Joined: Wed Dec 04, 2013 10:46 pm

Re: Multiple Sessions per user issue

Post by HintonIT » Wed Jun 07, 2017 2:00 pm

All of the User settings are defaults I beleive:
Ip - Dynamic
Addressing method - NAT
Allow access to networks - blank (set in group permissions)
Access From - not checked for both options
Configure VPN gateway - No
Configure DMZ address - No

Do group settings affect this as well?

novaflash
I should be on the dev team.
Posts: 720
Joined: Fri Apr 13, 2012 8:43 pm

Re: Multiple Sessions per user issue

Post by novaflash » Wed Jun 07, 2017 2:21 pm

Group settings should not affect this, no. We usually advise that if you need a user with specific access to subnets, that you create a group, set the parameters for access rules there, and assign an empty user account to that group, so it inherits those settings.

One more thing;

Changing a setting and clicking 'save settings' is not enough. You must also click 'update running servers' or it won't use the new settings until you restart the Access Server or update running servers later during some other changes you could be doing in the future.

HintonIT
OpenVpn Newbie
Posts: 7
Joined: Wed Dec 04, 2013 10:46 pm

Re: Multiple Sessions per user issue

Post by HintonIT » Wed Jun 07, 2017 3:11 pm

Yes that is exactly how I have it setup. And yes I have updated the running server, and the system has been rebooted a few times. This has been an issue for months, I have just got around to looking into it.

profileadmin
OpenVpn Newbie
Posts: 9
Joined: Fri Mar 09, 2018 12:40 am

Re: Multiple Sessions per user issue

Post by profileadmin » Tue May 15, 2018 8:09 pm

Looks like this is an issue for everyone and they have not fixed it yet. Do a search and google, I see unresolved posts back from 2011.

By the way I am having the same issue, same settings as you and nothing for a fix.

novaflash
I should be on the dev team.
Posts: 720
Joined: Fri Apr 13, 2012 8:43 pm

Re: Multiple Sessions per user issue

Post by novaflash » Wed May 16, 2018 12:50 pm

It's not a bug, but it is something we can improve and make clearer to people, and we will, eventually. But I don't know how clear I can make this but, ANY setting AT ALL on the user account itself will lead to the account not allowed multiple connections. For example, if you use access control on a user, that user cannot accept multiple connections. If you check the box to allow acces from private subnets, that user cannot accept multiple connections. If you use a static IP on this user, it cannot accept multiple connections. I don't really know how clear to make this but the error message it shows you is really REALLY correct and not a bug at all:

multiple concurrent connections denied due to user-specific properties

Post Reply