Can't login after deployment

Post Reply
dmargoi
OpenVpn Newbie
Posts: 3
Joined: Fri Mar 31, 2017 8:56 am

Can't login after deployment

Post by dmargoi » Fri Mar 31, 2017 8:58 am

I am trying the default username and pass to ssh into the appliance with no sucess.

Using:

Username: root
Password: openvpnas

getting Access Denied

novaflash
OpenVPN Expert
Posts: 436
Joined: Fri Apr 13, 2012 8:43 pm

Re: Can't login after deployment

Post by novaflash » Fri Mar 31, 2017 9:11 am

Which appliance exactly are you referring to?

dmargoi
OpenVpn Newbie
Posts: 3
Joined: Fri Mar 31, 2017 8:56 am

Re: Can't login after deployment

Post by dmargoi » Fri Mar 31, 2017 9:26 am


novaflash
OpenVPN Expert
Posts: 436
Joined: Fri Apr 13, 2012 8:43 pm

Re: Can't login after deployment

Post by novaflash » Fri Mar 31, 2017 9:31 am

Right, okay. Use the console to log on.

Afterwards if you want to use the root account to SSH into the server, edit /etc/ssh/sshd_config and change the line with permitrootlogin without-password to yes, and save and exit. Set a decent password for the root account and restart the SSH service. Then you can use SSH.

Generally not a good idea to have SSH wide open with root login so that's why it's disabled by default, but console login will work. And if you want SSH root login, there's the way to do it. Enjoy.

novaflash
OpenVPN Expert
Posts: 436
Joined: Fri Apr 13, 2012 8:43 pm

Re: Can't login after deployment

Post by novaflash » Fri Mar 31, 2017 9:32 am

Forgot to add; probably better to just add a normal user account, use that to SSH in, and sudo up from there to root privileges.

dmargoi
OpenVpn Newbie
Posts: 3
Joined: Fri Mar 31, 2017 8:56 am

Re: Can't login after deployment

Post by dmargoi » Fri Mar 31, 2017 9:39 am

Correct.

tty doesn't work either. That's how i got to the SSH.

novaflash
OpenVPN Expert
Posts: 436
Joined: Fri Apr 13, 2012 8:43 pm

Re: Can't login after deployment

Post by novaflash » Fri Mar 31, 2017 2:19 pm

Pretty damn sure it works to log in to the console, because I tried it just now with a freshly deployed OVA; works.

Post Reply