OpenVPN with AD (users failing)

Post Reply
fr0stxm
OpenVpn Newbie
Posts: 2
Joined: Fri Aug 11, 2017 11:19 am

OpenVPN with AD (users failing)

Post by fr0stxm » Fri Aug 11, 2017 11:34 am

Afternoon all,

I've been looking around and searched Google, the forum for answers to the following so hopefully someone can help..

I've setup an OpenVPN server within AWS, using their AMI and connected it to LDAP for AD authentication; however when I attempt to connect with my user it rejects with

Code: Select all

LDAP exception on ldap://192.168.8.42/ (facility='search (u'DC=domain,DC=local', 2, u'(&(sAMAccountName=domain\\5user\\2ename)(CN=SSLVPN-Users,OU=Security Groups,OU=Groups,DC=domain,DC=local))')'): user not found that meets specified requirements: CN=SSLVPN-Users,OU=Security Groups,OU=Groups,DC=domain,DC=local: auth/authldap:127,python2.7
Username: domain\user.name
I've tried with and without the domain prefix.

If I run ldapsearch against the same server my user does return.. Now looking at the error message, i can see that it's replacing the period with elements.. Could this be the cause?

Connection details:

Code: Select all

Host: 192.168.8.42
Base DN: DC=domain,DC=local
Additional LDAP: CN=SSLVPN-Users,OU=Security Groups,OU=Groups,DC=domain,DC=local
The SSLVPN-Users group contains a list of AD users that should have access to the VPN service. I have not added them to OpenVPN > User Management > User Permissions.

Thanks guys..

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 3348
Joined: Fri Jun 03, 2016 1:17 pm

Re: OpenVPN with AD (users failing)

Post by TinCanTech » Fri Aug 11, 2017 11:51 am


fr0stxm
OpenVpn Newbie
Posts: 2
Joined: Fri Aug 11, 2017 11:19 am

Re: OpenVPN with AD (users failing)

Post by fr0stxm » Fri Aug 11, 2017 12:05 pm

I don't appear to be able to edit this:

OpenVPN Access Server: 2.1.9

I assume because I have a license, you would like me to submit to OpenVPn directly and not via the forum. :/

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 3348
Joined: Fri Jun 03, 2016 1:17 pm

Re: OpenVPN with AD (users failing)

Post by TinCanTech » Fri Aug 11, 2017 1:38 pm

An Access Server support person can advise you further.

Post Reply