Issue upgrading to AS 2.9.2 for Ubuntu 18, 64 bits

Business solution to host your own OpenVPN server with web management interface and bundled clients.
Post Reply
rokeeffe
OpenVpn Newbie
Posts: 15
Joined: Wed Apr 01, 2015 4:11 pm

Issue upgrading to AS 2.9.2 for Ubuntu 18, 64 bits

Post by rokeeffe » Sun Aug 01, 2021 9:53 am

Hi,

My normal upgrade path is to download the latest package for my OS and install via dpkg.
Whilst trying to do this with version 2.9.2 I get the following errors:

Code: Select all

Setting up openvpn-as (2.9.2-04614689-Ubuntu18) ...
Backing up configuration and DB files to /usr/local/openvpn_as/etc/backup/2021-08-01T10:45:53+01:00 before update.
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "<frozen zipimport>", line 241, in load_module
  File "<frozen zipimport>", line 721, in _get_module_code
zipimport.ZipImportError: can't find module 'pyovpn'
I have also tried upgrading via the apt-get method, same issue with pyovpn missing though.

If I do a locate on pyovpn I get the following:

Code: Select all

# locate pyovpn
/usr/local/lib/python3.8/dist-packages/pyovpn_as
/usr/local/lib/python3.8/dist-packages/pyovpn_as-0.0.6.dist-info
/usr/local/lib/python3.8/dist-packages/pyovpn_as/__init__.py

Strikes me more a Python issue than an OpenVPN issue, however If I try version 2.8.7 it will install fine, so perhaps the issue is with the particular package.
Unfortunately the 2.8.7 package is no longer on my machine, some over zealous clean up saw it deleted. So I have a broken OpenVPN AS server at the moment.

So I am wondering does anyone have any input on the above errors or failing that a means to download the 2.8.7 package? I've tried looking for it but not coming up with much.

Thanks in advance,
R.

chilinux
OpenVPN Power User
Posts: 122
Joined: Thu Mar 28, 2013 8:31 am

Re: Issue upgrading to AS 2.9.2 for Ubuntu 18, 64 bits

Post by chilinux » Sun Aug 01, 2021 10:26 am

I do *not* recommend continuing to use 2.8.7 as it has known security issues. However, you can download/install it via this command:

sudo apt install openvpn-as=2.8.7-c7d6c210-Ubuntu18

Instead I would recommend reverting back to 2.8.8 instead using this command:

sudo apt install openvpn-as=2.8.8-cbf850a0-Ubuntu18

You will also need to restore the configuration and DB files from the backup placed in /usr/local/openvpn_as/etc/backup/2021-08-01T10:45:53+01:00

Version 2.8.8 should be compatible with all the same configuration and DB files that 2.8.7 was using.

I would recommend opening a ticket with OpenVPN AS support. They can walk you through the process of reverting to 2.8.8 if you need help with that. But they also can help troubleshoot the problem with the upgrade to 2.9.2. It would be preferable to have them explore why this problem occurred so this can be kept from ever taking place in future 2.9.x versions.

rokeeffe
OpenVpn Newbie
Posts: 15
Joined: Wed Apr 01, 2015 4:11 pm

Re: Issue upgrading to AS 2.9.2 for Ubuntu 18, 64 bits

Post by rokeeffe » Sun Aug 01, 2021 10:47 am

Up and running, thanks Chilinux!

I installed 2.8.8. which is confirmed working. I tried upgrading to 2.9.0 and that also breaks with the same errors, so it looks like 2.8.8 is what'll be running for a bit.

In terms of a ticket I think we are good, the box is a 'nice to have' rather than a piece of critical infrastructure, those get treated very differently.

Thank once more, I really appreciate the time and knowledge you have shared.

Post Reply