AS will not start after install

Business solution to host your own OpenVPN server with web management interface and bundled clients.
Post Reply
emgccshx
OpenVpn Newbie
Posts: 1
Joined: Thu Jul 01, 2021 7:24 am

AS will not start after install

Post by emgccshx » Thu Jul 01, 2021 7:34 am

I have followed the installation instructions for AS on Ubuntu 20.04 and I am getting the following error:
openvpnas.service - OpenVPN Access Server
Loaded: loaded (/lib/systemd/system/openvpnas.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2021-07-01 06:42:21 UTC; 4s ago
Process: 2824 ExecStart=/usr/local/openvpn_as/scripts/openvpnas --nodaemon --logfile=/var/log/openvpnas.log --pidfile= (code=exited, status=1/FAILURE)
Main PID: 2824 (code=exited, status=1/FAILURE)

Jul 01 06:42:21 OPENVPNSYD systemd[1]: Started OpenVPN Access Server.
Jul 01 06:42:21 OPENVPNSYD openvpnas[2825]: Traceback (most recent call last):
Jul 01 06:42:21 OPENVPNSYD openvpnas[2825]: File "<string>", line 1, in <module>
Jul 01 06:42:21 OPENVPNSYD openvpnas[2825]: File "<frozen zipimport>", line 241, in load_module
Jul 01 06:42:21 OPENVPNSYD openvpnas[2825]: File "<frozen zipimport>", line 721, in _get_module_code
Jul 01 06:42:21 OPENVPNSYD openvpnas[2825]: zipimport.ZipImportError: can't find module 'pyovpn'
Jul 01 06:42:21 OPENVPNSYD systemd[1]: openvpnas.service: Main process exited, code=exited, status=1/FAILURE
Jul 01 06:42:21 OPENVPNSYD systemd[1]: openvpnas.service: Failed with result 'exit-code'.
I am running it on Ubuntu 21.04, so I thought there might be some issues that would arise during installation, but everything went nicely. The only problem is the service won't start. I know that it will run on Ubuntu 20.04, so is the issue with 21.04?

Any and all help appreciated.

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 228
Joined: Tue Feb 16, 2021 10:41 am

Re: AS will not start after install

Post by openvpn_inc » Thu Jul 01, 2021 8:19 am

Hello emgccshx,

We do not build for or support Ubuntu 21.04, sorry. Yes the issue is with 21.04.

Please use Access Server on a supported operating system, preferably Ubuntu 20.04 LTS (Long Term Support) version.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

ylavoie
OpenVpn Newbie
Posts: 2
Joined: Thu Mar 31, 2016 3:50 pm

Re: AS will not start after install

Post by ylavoie » Tue Jul 20, 2021 7:06 pm

I installed the 20.04 version and it still fails.

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 228
Joined: Tue Feb 16, 2021 10:41 am

Re: AS will not start after install

Post by openvpn_inc » Wed Jul 21, 2021 6:01 pm

Hi emgccshx,

You mean you deploy a fresh Ubuntu 20.04 installation and installed the correct repository for it right?
Because we actually have 2 repository for ubuntu 20. Which is the one with x86_64 and the one for arm64.

Can you confirm which one you used? Please confirm first which ubuntu version you are using via:

Code: Select all

lsb_release -a
Then check again? Can you as well provide the exact error you are getting? Was it the same error as the one you previously provided?
ylavoie wrote:
Tue Jul 20, 2021 7:06 pm
I installed the 20.04 version and it still fails.
Regards,
Crowley
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

chilinux
OpenVPN Power User
Posts: 115
Joined: Thu Mar 28, 2013 8:31 am

Re: AS will not start after install

Post by chilinux » Thu Jul 22, 2021 3:50 am

openvpn_inc wrote:
Wed Jul 21, 2021 6:01 pm
You mean you deploy a fresh Ubuntu 20.04 installation and installed the correct repository for it right?
Because we actually have 2 repository for ubuntu 20. Which is the one with x86_64 and the one for arm64.
OpenVPN AS has two architectures for 20.04 but it is the same repository.

If you compare the option 1 install instructions for x86_64 and arm64, you will see they are the same. The same exact openvpn-as-repo.list file is created for the apt to use. It is left to apt to determine the right architecture packages to download and install.

It is possible to download the wrong architecture by following install option 2. However, dpkg should refuse to install the incorrect package and should issue an error message similar to this:

Code: Select all

dpkg: error processing archive openvpn-as-latest-ubuntu20.arm_64.deb (--install):
 package architecture (arm64) does not match system (amd64)
As such, either apt or dpkg should keep the user from shooting themselves in the wrong architecture foot (or arm).

The error returned by systemd under 20.04 should be very different from the error returned under 21.04 but the OP hasn't supplied an updated copy of the error. Without it, I feel like we are shooting in the dark as to what the new problem is. Hopefully we will get more breadcrumbs from the OP to help solve the riddle as I hate being left in the dark.

Post Reply