VPN Connection Problems

Weekly dev snapshots are available for testing.
We talk about them here. Testing features in the dev snapshot helps the features make it to stable.
Forum rules
Please report your experience with testing branch. Include what you were using and how
If there is a problem, the more info the better!
Post Reply
widmark
OpenVpn Newbie
Posts: 15
Joined: Wed Apr 11, 2012 7:26 pm

VPN Connection Problems

Post by widmark » Thu Apr 12, 2012 10:16 pm

I am unable to connect to my recently configured VPN Server with OpenVPN. I configured openvpn.ovpn file to connect using the dynamic public IP address assigned by my ISP (TimeWarner Cable) to my router (172.XXX.XXX.XXX). I am using the config and ca certificate files generated by my VPN server (Synology DiskStation - Linux based). I opened port 1194 on my router. I am on Windows 7.

What am I doing wrong? Please help. Below is the info provided by OpenVPN's dialogue box after attempting to connect. I have tried various IP addresses (internal subnets 10.X.X.X and 192.168.X.X) and all have the same result.

---------------------------
Thu Apr 12 09:16:56 2012 OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Dec 15 2011
Thu Apr 12 09:17:00 2012 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA. OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Thu Apr 12 09:17:00 2012 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Thu Apr 12 09:17:00 2012 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Thu Apr 12 09:17:00 2012 LZO compression initialized
Thu Apr 12 09:17:00 2012 UDPv4 link local (bound): [undef]:1194
Thu Apr 12 09:17:00 2012 UDPv4 link remote: 172.XXX.XXX.XXX:1194
Thu Apr 12 09:18:00 2012 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Thu Apr 12 09:18:00 2012 TLS Error: TLS handshake failed
Thu Apr 12 09:18:00 2012 SIGUSR1[soft,tls-error] received, process restarting

widmark
OpenVpn Newbie
Posts: 15
Joined: Wed Apr 11, 2012 7:26 pm

Re: VPN Connection Problems

Post by widmark » Fri Apr 13, 2012 2:31 pm

Issue resolved. Port 1194 was still blocked by the firewall on the NAS/VPN Server.

Post Reply