Disable TAP version check, how?

How to customize and extend your OpenVPN installation.
Post Reply
telnet
OpenVpn Newbie
Posts: 1
Joined: Wed Jan 25, 2012 8:47 pm

Disable TAP version check, how?

Post by telnet » Wed Jan 25, 2012 8:56 pm

Hi,

I'm using OpenVPN v2.2.2 on Win7 x64 and am currently looking into employing a custom TAP Win32 adapter driver.

Problem is OVPN does not like the driver is a lower version than required and terminates with:

Code: Select all

TAP-Win32 Driver Version 9.6

This version of OpenVPN requires a TAP-Win32 driver that is at least version 9.9 -- If you recently upgraded your OpenVPN distribution, a reboot is probably required at this point to get Windows to see the new driver.
Now I've tried all things imaginable, even modifying the driver files's version resource, but it seems OVPN is looking eslewhere to check the version info.

Is there any way around this, ideally by disabling the version check?

Many thanks!

User avatar
janjust
Forum Team
Posts: 2703
Joined: Fri Aug 20, 2010 2:57 pm
Location: Amsterdam
Contact:

Re: Disable TAP version check, how?

Post by janjust » Wed Feb 01, 2012 9:47 am

nocando.
you'd have to build your own version of openvpn, BUT you should really use the 9.9 driver, as there were some nasty win7 related issues in tap-win32 9.6 & 9.8.

Post Reply