Management Interface - Question regarding --management-query-passwords

How to customize and extend your OpenVPN installation.
Post Reply
ogeisser
OpenVpn Newbie
Posts: 2
Joined: Sun Feb 21, 2021 11:20 am

Management Interface - Question regarding --management-query-passwords

Post by ogeisser » Sun Feb 21, 2021 11:43 am

Hi,

I'm writing a small program which controls the OpenVPN client via the management interface.

I'm starting the OpenVPN client with --management and --management-query-passwords in addition to all the other needed configuration.

I can then connect my control program to the management interface socket.

Everything works fine up to here and after connecting to the socket I receive the following welcome INFO message:

>INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info

And after this welcome message I sometimes receive:

>PASSWORD:Need 'Auth' username/password

With "sometimes" I mean: in 1 of 5 times I receive the >PASSWORD: Need 'Auth' username/password message.
In all other cases I receive nothing.

My expectation is that I will always receive the "Need Auth" message because I've configured --management-query-passwords

But it seems that there is some race condition which triggers the "Need Auth" message only sometimes.

Is this a bug or can someone explain to me this behaviour?

I'm using the following OpenVPN version:
OpenVPN 2.4.5 x86_64-apple-darwin14 [SSL (OpenSSL)] [MH/RECVDA] [AEAD] built on Mar 19 2020

Best,
Oliver

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 9018
Joined: Fri Jun 03, 2016 1:17 pm

Re: Management Interface - Question regarding --management-query-passwords

Post by TinCanTech » Sun Feb 21, 2021 8:29 pm

Sounds like a bug in your code.

Post Reply