tunneling openvpn through UDP tunnel but there is no ping

How to customize and extend your OpenVPN installation.
Post Reply
ryn
OpenVpn Newbie
Posts: 1
Joined: Wed Aug 30, 2017 9:15 pm

tunneling openvpn through UDP tunnel but there is no ping

Post by ryn » Wed Aug 30, 2017 9:34 pm

Hi

I'm trying to pass the openvpn traffic trough a UDP tunnel by these configs :
Note: tunnel is already established on port 23460 server and 52320 client machine;
Both server and client have static valid IP address.

Server Side:

Code: Select all

proto udp
dev tap
remote SERVER_IP 23460
ifconfig 10.0.8.2 255.255.255.0
port 52320
verb 3
persist-key
persist-tun
secret static.key
status /var/log/openvpn-status.log
log-append /var/log/openvpn
Client Side:

Code: Select all

proto udp
dev tap
remote CLIENT_IP 52320
ifconfig 10.0.8.1 255.255.255.0
port 23460
verb 3
persist-key
persist-tun
secret static.key
status /var/log/openvpn-status.log
log-append /var/log/openvpn

and then run openvpn like this:

Server:

Code: Select all

openvpn --cd $dir --daemon --config dynamic.conf
Client:

Code: Select all

route add -host SERVER_IP gw CLIENT_IP
route add -host 4.2.2.3 gw CLIENT_IP

openvpn --cd $dir --daemon --config dynamic.conf

route del default
route add default gw 10.0.8.2

My iptables are empty and policy is Accept;


I cant ping neither server tap device ip (10.0.8.2) nor any other ip/domain from client

Can anyone help me with this? what can be the problem?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2828
Joined: Fri Jun 03, 2016 1:17 pm

Re: tunneling openvpn through UDP tunnel but there is no ping

Post by TinCanTech » Wed Aug 30, 2017 11:14 pm

ip forwarding ..

klanimantsi
OpenVPN User
Posts: 11
Joined: Mon Sep 04, 2017 9:00 am

Re: tunneling openvpn through UDP tunnel but there is no ping

Post by klanimantsi » Mon Sep 18, 2017 9:48 am

how did it go with the IP forwarding?

Post Reply