Multiple OpenVPN Daemons on different ports = erratic behavior

How to customize and extend your OpenVPN installation.
Post Reply
null
OpenVpn Newbie
Posts: 3
Joined: Thu Dec 07, 2017 1:44 am

Multiple OpenVPN Daemons on different ports = erratic behavior

Post by null » Thu Dec 07, 2017 2:07 am

Hello all!

I'm running 2 openvpn server daemons, one on port 4500 and one on port 1194

The 1194 came first, and I just cp'd the config file and changed the port, then launched/enabled the service with systemctl.

Here's the weird part:
I'm able to connect to port 1194, do stuff on it like browse the internet and access 10.8.0.1 (the server itself)
On port 4500, openvpn says I connected, but then tells me this:
2017-12-06 20:19:17 *Tunnelblick: After 30.0 seconds, gave up trying to fetch IP address information using the ipInfo host's name after connecting.
2017-12-06 20:19:52 *Tunnelblick: After 30.0 seconds, gave up trying to fetch IP address information using the ipInfo host's IP address after connecting.

Does that mean that the server's DHCP (or whatever is the openvpn equivalent) is not responding? The server config file points to the same CA certs, etc.

My end goal in this is for both ports to ideally serve up the same subnet, but if that's not a possibility, both should work for forwarding/proxying/routing connections.

Thanks in advance for any help!

Best
-D

TiTex
OpenVPN Expert
Posts: 245
Joined: Tue Apr 12, 2011 6:22 am

Re: Multiple OpenVPN Daemons on different ports = erratic behavior

Post by TiTex » Thu Dec 07, 2017 5:56 pm

did you change the openvpn subnet on the second one ?

null
OpenVpn Newbie
Posts: 3
Joined: Thu Dec 07, 2017 1:44 am

Re: Multiple OpenVPN Daemons on different ports = erratic behavior

Post by null » Fri Dec 08, 2017 4:45 am

No. And now the openvpn server on the main port is messed up I think. Is that an issue?

TiTex
OpenVPN Expert
Posts: 245
Joined: Tue Apr 12, 2011 6:22 am

Re: Multiple OpenVPN Daemons on different ports = erratic behavior

Post by TiTex » Fri Dec 08, 2017 7:19 pm

what do you think ? :)

null
OpenVpn Newbie
Posts: 3
Joined: Thu Dec 07, 2017 1:44 am

Re: Multiple OpenVPN Daemons on different ports = erratic behavior

Post by null » Sat Dec 09, 2017 3:32 am

I figured it out before reading your response haha, I'm so stupid. Both were sharing the same subnet AND tun if

Post Reply