Open VPN configuration errors [Solved]

This is where we can discuss what we would like to see added or changed in OpenVPN.
Post Reply
j.agtys
OpenVPN User
Posts: 17
Joined: Sat Dec 01, 2018 3:59 pm

Open VPN configuration errors [Solved]

Post by j.agtys » Sun Dec 02, 2018 12:01 am

Hello.

I posted in configurations and did not find a solution to my problem.

I am trying to setup a VPN. I keep getting the same error on my server log.

Code: Select all

Sat Dec  1 17:29:55 2018 OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Jun 22 2017
Sat Dec  1 17:29:55 2018 library versions: OpenSSL 1.0.2g  1 Mar 2016, LZO 2.08
Sat Dec  1 17:29:55 2018 Diffie-Hellman initialized with 2048 bit key
Sat Dec  1 17:29:55 2018 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Sat Dec  1 17:29:55 2018 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sat Dec  1 17:29:55 2018 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sat Dec  1 17:29:55 2018 Socket Buffers: R=[212992->212992] S=[212992->212992]
Sat Dec  1 17:29:55 2018 ROUTE_GATEWAY 206.217.192.209/255.255.255.240 IFACE=eth0 HWADDR=00:16:3e:47:dc:73
Sat Dec  1 17:29:55 2018 TUN/TAP device tun0 opened
Sat Dec  1 17:29:55 2018 TUN/TAP TX queue length set to 100
Sat Dec  1 17:29:55 2018 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Sat Dec  1 17:29:55 2018 /sbin/ip link set dev tun0 up mtu 1500
Sat Dec  1 17:29:55 2018 /sbin/ip addr add dev tun0 local 10.7.0.1 peer 10.7.0.2
Sat Dec  1 17:29:55 2018 /sbin/ip route add 10.7.0.0/24 via 10.7.0.2
Sat Dec  1 17:29:55 2018 GID set to nogroup
Sat Dec  1 17:29:55 2018 UID set to nobody
Sat Dec  1 17:29:55 2018 UDPv4 link local (bound): [undef]
Sat Dec  1 17:29:55 2018 UDPv4 link remote: [undef]
Sat Dec  1 17:29:55 2018 MULTI: multi_init called, r=256 v=256
Sat Dec  1 17:29:55 2018 IFCONFIG POOL: base=10.7.0.4 size=62, ipv6=0
Sat Dec  1 17:29:55 2018 IFCONFIG POOL LIST
Sat Dec  1 17:29:55 2018 Initialization Sequence Completed
Sat Dec  1 17:30:25 2018 Authenticate/Decrypt packet error: packet HMAC authentication failed
Sat Dec  1 17:30:25 2018 TLS Error: incoming packet authentication failed from [AF_INET]24.123.237.82:53648
Sat Dec  1 17:30:28 2018 Authenticate/Decrypt packet error: packet HMAC authentication failed
Sat Dec  1 17:30:28 2018 TLS Error: incoming packet authentication failed from [AF_INET]24.123.237.82:53648
Sat Dec  1 17:30:31 2018 Authenticate/Decrypt packet error: packet HMAC authentication failed

My two configurations:

server

port 1194
proto udp
dev tun
ca ca.crt
cert jc-vps.crt
key jc-vps.key
dh dh2048.pem
server 10.7.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "redirect-gateway def1 bypass-dhcp"
keepalive 10 120
tls-auth ta.key 0
key-direction 0
cipher AES-128-CBC
comp-lzo
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
verb 3



client

client
dev tun
proto udp
remote *.com 1194
resolv-retry infinite
nobind
user nobody
group nogroup
persist-key
persist-tun
#ca ca.crt
#cert client.crt
#key client.key
cipher AES-128-CBC
auth SHA256
remote-cert-tls server
;tls-auth ta.key 1
comp-lzo
verb 3
<ca>
-----BEGIN CERTIFICATE-----
(removed)
-----END CERTIFICATE-----
</ca>
<cert>
(removed)
-----BEGIN CERTIFICATE-----
(removed)
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
(removed)
-----END PRIVATE KEY-----
</key>
key-direction 1
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
(removed)
-----END OpenVPN Static key V1-----
</tls-auth>

Last edited by j.agtys on Sun Dec 02, 2018 11:26 pm, edited 1 time in total.

j.agtys
OpenVPN User
Posts: 17
Joined: Sat Dec 01, 2018 3:59 pm

Re: Open VPN configuration errors

Post by j.agtys » Sun Dec 02, 2018 11:25 pm

Alright, it looks like I may have posted this in the wrong place. That's a little embarrassing, but the good news is that I got it working.

Post Reply