NAT/masquerading is enabled, how to disable?

This forum is for general conversation and user-user networking.
Post Reply
EBCF
OpenVpn Newbie
Posts: 2
Joined: Thu Jun 25, 2020 2:54 pm

NAT/masquerading is enabled, how to disable?

Post by EBCF » Thu Jun 25, 2020 2:57 pm

I set up OpenVPN using the Turnkey Linux appliance. It works, but the appliance uses NAT/masquerading by default, meaning VPN clients aren't directly visible to the corporate network. I'd like to change this. I think what I want is a routed setup without NAT (and with the addition of an appropriate static route on our office's default gateway). I'm not familiar with iptables and masquerading and since the distro set things up I'm not sure what needs to be looked at and changed.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7389
Joined: Fri Jun 03, 2016 1:17 pm

Re: NAT/masquerading is enabled, how to disable?

Post by TinCanTech » Thu Jun 25, 2020 4:56 pm

EBCF wrote:
Thu Jun 25, 2020 2:57 pm
the corporate network
Have you considered hiring a professional ?

EBCF
OpenVpn Newbie
Posts: 2
Joined: Thu Jun 25, 2020 2:54 pm

Re: NAT/masquerading is enabled, how to disable?

Post by EBCF » Fri Jun 26, 2020 3:00 pm

Following on from this superuser post, https://superuser.com/questions/974327/ ... in-openvpn , I found where the iptables rules were being set. In /etc/iptables.up.rules on this appliance, others might differ. I commented out all the lines in the nat section and rebooted and after adding the static route on the office router it appears to be working.

Post Reply