OpenWrt rebooting after start the openvpn client

This forum is for general conversation and user-user networking.
Post Reply
Orlov
OpenVpn Newbie
Posts: 1
Joined: Thu Apr 02, 2020 9:38 am

OpenWrt rebooting after start the openvpn client

Post by Orlov » Thu Apr 02, 2020 9:44 am

After starting openvpn (client), after a few seconds (from 2 to 40), OpenWRT reboots. How to find out why?

I connected to the server with android and linux, everything works without problems.

I changed UCP to TCP, turned off the firewall, turned off compression, stopped the dev parameter in the tap value. The result did not change.

When connected to a third-party vpn server (protonvpn), the situation does not change.

It seems that OpenWRT rebooted after sending data via vpn. For example, ping instantly killed the system. With inaction, the system could not restart for 30-40 seconds. Although most often this happens immediately after connecting.

Client

# ubus call system board

Code: Select all

{
            "kernel": "3.10.49",
            "hostname": "UnwiredOne",
            "system": "Atheros AR9330 rev 1",
            "model": "Unwired Devices Unwired One board",
            "release": {
                    "distribution": "OpenWrt",
                    "version": "Barrier Breaker",
                    "revision": "r47068",
                    "codename": "barrier_breaker",
                    "target": "ar71xx\/generic",
                    "description": "OpenWrt Barrier Breaker 14.07"
            }
}
# openvpn --version

Code: Select all

OpenVPN 2.3.6 mips-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Jan  6 2015
    library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
# cat client.ovpn

Code: Select all

client
    dev tun
    proto udp
    remote X.X.X.X 1194
    resolv-retry infinite
    nobind
    user nobody
    group nogroup
    persist-key
    persist-tun
    remote-cert-tls server
    comp-lzo
    verb 5
    key-direction 1
    script-security 2
    up /etc/openvpn/update-resolv-conf
    down /etc/openvpn/update-resolv-conf
    <ca>...</ca>
    <cert>...</cert>
    <key>...</key>
    <tls-auth>...</tls-auth>
# cat /etc/config/network

Code: Select all

config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd4e:ad8a:b15e::/48'
    
    config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '1'
    
    config switch_vlan
            option device 'switch0'
            option vlan '1'
            option ports '0 1 3'
    
    config interface 'wwan'
            option proto 'dhcp'
    
    config interface '3g'
            option proto '3g'
            option device '/dev/ttyUSB0'
            option service 'umts'
            option apn 'internet'
    
    config interface 'vpn0'
            option ifname 'tun0'
            option proto 'none'
            option auto '1'
# openvpn /etc/openvpn/client1.ovpn

Code: Select all

Wed Apr  1 18:20:38 2020 us=777485 OpenVPN 2.3.6 mips-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Jan  6 2015
    Wed Apr  1 18:20:38 2020 us=779657 library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
    Wed Apr  1 18:20:38 2020 us=781988 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
    Wed Apr  1 18:20:38 2020 us=793715 Control Channel Authentication: tls-auth using INLINE static key file
    Wed Apr  1 18:20:38 2020 us=795928 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed Apr  1 18:20:38 2020 us=798144 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed Apr  1 18:20:38 2020 us=800536 LZO compression initialized
    Wed Apr  1 18:20:38 2020 us=804739 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
    Wed Apr  1 18:20:38 2020 us=807505 Socket Buffers: R=[163840->131072] S=[163840->131072]
    Wed Apr  1 18:20:38 2020 us=810551 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
    Wed Apr  1 18:20:38 2020 us=812971 NOTE: UID/GID downgrade will be delayed because of --client, --pull, or --up-delay
    Wed Apr  1 18:20:38 2020 us=815006 UDPv4 link local: [undef]
    Wed Apr  1 18:20:38 2020 us=816983 UDPv4 link remote: [AF_INET]Y.Y.Y.Y:1194
    WRWed Apr  1 18:20:38 2020 us=875520 TLS: Initial packet from [AF_INET]Y.Y.Y.Y:1194, sid=b83823a2 5303a60f
    WWWRRWRWed Apr  1 18:20:38 2020 us=983372 VERIFY OK: depth=1, CN=Easy-RSA CA
    Wed Apr  1 18:20:38 2020 us=994932 Validating certificate key usage
    Wed Apr  1 18:20:38 2020 us=996835 ++ Certificate has key usage  00a0, expects 00a0
    Wed Apr  1 18:20:38 2020 us=998078 VERIFY KU OK
    Wed Apr  1 18:20:39 2020 us=953 Validating certificate extended key usage
    Wed Apr  1 18:20:39 2020 us=2925 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
    Wed Apr  1 18:20:39 2020 us=5158 VERIFY EKU OK
    Wed Apr  1 18:20:39 2020 us=7180 VERIFY OK: depth=0, CN=server
    WRWWWWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRRRRWWWRRRWed Apr  1 18:20:41 2020 us=626297 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
    Wed Apr  1 18:20:41 2020 us=628023 NOTE: --mute triggered...
    WWed Apr  1 18:20:41 2020 us=633022 4 variation(s) on previous 10 message(s) suppressed by --mute
    Wed Apr  1 18:20:41 2020 us=634789 [server] Peer Connection Initiated with [AF_INET]Y.Y.Y.Y:1194
    Wed Apr  1 18:20:43 2020 us=978684 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
    WRRWed Apr  1 18:20:44 2020 us=32029 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,route 10.8.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5'
    Wed Apr  1 18:20:44 2020 us=34675 OPTIONS IMPORT: timers and/or timeouts modified
    Wed Apr  1 18:20:44 2020 us=36502 OPTIONS IMPORT: --ifconfig/up options modified
    Wed Apr  1 18:20:44 2020 us=37438 OPTIONS IMPORT: route options modified
    Wed Apr  1 18:20:44 2020 us=47521 TUN/TAP device tun0 opened
    Wed Apr  1 18:20:44 2020 us=49579 TUN/TAP TX queue length set to 100
    Wed Apr  1 18:20:44 2020 us=51504 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Wed Apr  1 18:20:44 2020 us=52054 /sbin/ifconfig tun0 10.8.0.6 pointopoint 10.8.0.5 mtu 1500
    Wed Apr  1 18:20:44 2020 us=108306 /etc/openvpn/update-resolv-conf tun0 1500 1542 10.8.0.6 10.8.0.5 init
    Wed Apr  1 18:20:44 2020 us=250005 /sbin/route add -net Y.Y.Y.Y netmask 255.255.255.255 gw 192.168.1.1
    Wed Apr  1 18:20:44 2020 us=300169 /sbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 10.8.0.5
    Wed Apr  1 18:20:44 2020 us=339965 /sbin/route add -net 128.0.0.0 netmask 128.0.0.0 gw 10.8.0.5
    Wed Apr  1 18:20:44 2020 us=383783 /sbin/route add -net 10.8.0.1 netmask 255.255.255.255 gw 10.8.0.5
    Wed Apr  1 18:20:44 2020 us=413375 GID set to nogroup
    Wed Apr  1 18:20:44 2020 us=413776 UID set to nobody
    Wed Apr  1 18:20:44 2020 us=413997 Initialization Sequence Completed
    WWRWRRWWRRWWRRW
Runtime Logging (OpenWRT)

Code: Select all

Wed Apr  1 18:20:44 2020 daemon.notice netifd: Interface 'vpn0' is enabled
    Wed Apr  1 18:20:44 2020 daemon.notice netifd: Network device 'tun0' link is up
    Wed Apr  1 18:20:44 2020 daemon.notice netifd: Interface 'vpn0' has link connectivity
    Wed Apr  1 18:20:44 2020 daemon.notice netifd: Interface 'vpn0' is setting up now
    Wed Apr  1 18:20:44 2020 daemon.notice netifd: Interface 'vpn0' is now up
    Wed Apr  1 18:20:44 2020 daemon.info dnsmasq[1236]: exiting on receipt of SIGTERM
    Wed Apr  1 18:20:44 2020 user.notice firewall: Reloading firewall due to ifup of vpn0 (tun0)
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: started, version 2.71 cachesize 150
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: using nameserver 8.8.4.4#53
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: using nameserver 8.8.8.8#53
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: reading /etc/resolv.conf
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: using nameserver 8.8.4.4#53
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: using nameserver 8.8.8.8#53
    Wed Apr  1 18:20:45 2020 daemon.warn dnsmasq[4173]: ignoring nameserver 127.0.0.1 - local interface
    Wed Apr  1 18:20:45 2020 daemon.info dnsmasq[4173]: read /etc/hosts - 1 addresses
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4173]: exiting on receipt of SIGTERM
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: started, version 2.71 cachesize 150
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using local addresses only for domain lan
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using nameserver 8.8.4.4#53
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using nameserver 8.8.8.8#53
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: reading /tmp/resolv.conf.vpn
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using local addresses only for domain lan
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using nameserver 8.8.4.4#53
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using nameserver 8.8.8.8#53
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using nameserver 209.244.0.3#53
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: using nameserver 64.6.64.6#53
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: read /etc/hosts - 1 addresses
    Wed Apr  1 18:20:46 2020 daemon.info dnsmasq[4192]: read /tmp/hosts/dhcp - 0 addresses
    Wed Apr  1 14:30:28 2020 user.emerg syslog: this file has been obseleted. please call "/sbin/block mount" directly
    Wed Apr  1 14:30:28 2020 user.err syslog: /dev/mtdblock5 is already mounted
    Wed Apr  1 14:30:28 2020 user.emerg syslog: block: /dev/mtdblock5 is already mounted
    Wed Apr  1 14:30:30 2020 authpriv.warn dropbear[1008]: Failed loading /etc/dropbear/dropbear_ecdsa_host_key
    Wed Apr  1 14:30:30 2020 authpriv.info dropbear[1008]: Not backgrounding
    Wed Apr  1 14:30:35 2020 auth.err sshd[1021]: error: Bind to port 22 on :: failed: Address already in use.
    Wed Apr  1 14:30:35 2020 auth.err sshd[1021]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use.
    Wed Apr  1 14:30:35 2020 auth.crit sshd[1021]: fatal: Cannot bind any address.
    Wed Apr  1 14:30:35 2020 daemon.warn netifd: You have delegated IPv6-prefixes but haven't assigned them to any interface. Did you forget to set option ip6assign on your lan-interfaces?
    Wed Apr  1 14:30:35 2020 daemon.notice netifd: Interface '3g' is setting up now
    Wed Apr  1 14:30:35 2020 daemon.notice netifd: Interface 'loopback' is enabled
    Wed Apr  1 14:30:35 2020 daemon.notice netifd: Interface 'loopback' is setting up now
    Wed Apr  1 14:30:35 2020 daemon.notice netifd: Interface 'loopback' is now up
    Wed Apr  1 14:30:35 2020 daemon.notice netifd: Network device 'lo' link is up
    Wed Apr  1 14:30:35 2020 daemon.notice netifd: Interface 'loopback' has link connectivity
Server

# lsb_release -a

Code: Select all

No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 16.04 LTS
    Release:        16.04
    Codename:       xenial
# openvpn --version

Code: Select all

OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Jan  9 2019
    library versions: OpenSSL 1.0.2g-fips  1 Mar 2016, LZO 2.08
# cat /etc/openvpn/server.conf

Code: Select all

port 1194
    proto udp
    dev tun
    ca /etc/openvpn/ca.crt
    cert /etc/openvpn/server.crt
    key /etc/openvpn/server.key
    dh /etc/openvpn/dh.pem
    server 10.8.0.0 255.255.255.0
    ifconfig-pool-persist ipp.txt
    push "redirect-gateway def1 bypass-dhcp"
    keepalive 10 120
    tls-auth /etc/openvpn/ta.key
    comp-lzo
    user nobody
    group nogroup
    persist-key
    persist-tun
    status openvpn-status.log
    verb 5
    mute 10
# sudo openvpn --config /etc/openvpn/server.conf

Code: Select all

Wed Apr  1 18:18:50 2020 us=544920 Current Parameter Settings:
    Wed Apr  1 18:18:50 2020 us=544980   config = '/etc/openvpn/server.conf'
    Wed Apr  1 18:18:50 2020 us=545008   mode = 1
    Wed Apr  1 18:18:50 2020 us=545018   persist_config = DISABLED
    Wed Apr  1 18:18:50 2020 us=545027   persist_mode = 1
    Wed Apr  1 18:18:50 2020 us=545036   show_ciphers = DISABLED
    Wed Apr  1 18:18:50 2020 us=545045   show_digests = DISABLED
    Wed Apr  1 18:18:50 2020 us=545054   show_engines = DISABLED
    Wed Apr  1 18:18:50 2020 us=545065   genkey = DISABLED
    Wed Apr  1 18:18:50 2020 us=545074   key_pass_file = '[UNDEF]'
    Wed Apr  1 18:18:50 2020 us=545083 NOTE: --mute triggered...
    Wed Apr  1 18:18:50 2020 us=545101 272 variation(s) on previous 10 message(s) suppressed by --mute
    Wed Apr  1 18:18:50 2020 us=545111 OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Jan  9 2019
    Wed Apr  1 18:18:50 2020 us=545137 library versions: OpenSSL 1.0.2g-fips  1 Mar 2016, LZO 2.08
    Wed Apr  1 18:18:50 2020 us=545527 Diffie-Hellman initialized with 2048 bit key
    Wed Apr  1 18:18:50 2020 us=545692 WARNING: file '/etc/openvpn/server.key' is group or others accessible
    Wed Apr  1 18:18:50 2020 us=545848 WARNING: file '/etc/openvpn/ta.key' is group or others accessible
    Wed Apr  1 18:18:50 2020 us=545877 Control Channel Authentication: using '/etc/openvpn/ta.key' as a OpenVPN static key file
    Wed Apr  1 18:18:50 2020 us=545889 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed Apr  1 18:18:50 2020 us=545899 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed Apr  1 18:18:50 2020 us=545914 TLS-Auth MTU parms [ L:1542 D:1184 EF:66 EB:0 ET:0 EL:3 ]
    Wed Apr  1 18:18:50 2020 us=545935 Socket Buffers: R=[133120->133120] S=[133120->133120]
    Wed Apr  1 18:18:50 2020 us=546010 ROUTE_GATEWAY ON_LINK IFACE=venet0 HWADDR=00:00:00:00:00:00
    Wed Apr  1 18:18:50 2020 us=547302 TUN/TAP device tun0 opened
    Wed Apr  1 18:18:50 2020 us=547328 TUN/TAP TX queue length set to 100
    Wed Apr  1 18:18:50 2020 us=547361 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Wed Apr  1 18:18:50 2020 us=547384 /sbin/ip link set dev tun0 up mtu 1500
    Wed Apr  1 18:18:50 2020 us=556067 /sbin/ip addr add dev tun0 local 10.8.0.1 peer 10.8.0.2
    Wed Apr  1 18:18:50 2020 us=558129 /sbin/ip route add 10.8.0.0/24 via 10.8.0.2
    Wed Apr  1 18:18:50 2020 us=560809 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:143 ET:0 EL:3 AF:3/1 ]
    Wed Apr  1 18:18:50 2020 us=561299 GID set to nogroup
    Wed Apr  1 18:18:50 2020 us=561334 UID set to nobody
    Wed Apr  1 18:18:50 2020 us=561349 UDPv4 link local (bound): [undef]
    Wed Apr  1 18:18:50 2020 us=561359 UDPv4 link remote: [undef]
    Wed Apr  1 18:18:50 2020 us=561379 MULTI: multi_init called, r=256 v=256
    Wed Apr  1 18:18:50 2020 us=561412 IFCONFIG POOL: base=10.8.0.4 size=62, ipv6=0
    Wed Apr  1 18:18:50 2020 us=561433 ifconfig_pool_read(), in='client1,10.8.0.4', TODO: IPv6
    Wed Apr  1 18:18:50 2020 us=561445 succeeded -> ifconfig_pool_set()
    Wed Apr  1 18:18:50 2020 us=561454 ifconfig_pool_read(), in='client1,10.8.0.8', TODO: IPv6
    Wed Apr  1 18:18:50 2020 us=561466 succeeded -> ifconfig_pool_set()
    Wed Apr  1 18:18:50 2020 us=561477 IFCONFIG POOL LIST
    Wed Apr  1 18:18:50 2020 us=561487 client1,10.8.0.4
    Wed Apr  1 18:18:50 2020 us=561496 client1,10.8.0.8
    Wed Apr  1 18:18:50 2020 us=561524 Initialization Sequence Completed
    Wed Apr  1 18:20:38 2020 us=841127 MULTI: multi_create_instance called
    Wed Apr  1 18:20:38 2020 us=841200 X.X.X.X:58811 Re-using SSL/TLS context
    Wed Apr  1 18:20:38 2020 us=841233 X.X.X.X:58811 LZO compression initialized
    Wed Apr  1 18:20:38 2020 us=841331 X.X.X.X:58811 Control Channel MTU parms [ L:1542 D:1184 EF:66 EB:0 ET:0 EL:3 ]
    Wed Apr  1 18:20:38 2020 us=841345 X.X.X.X:58811 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:143 ET:0 EL:3 AF:3/1 ]
    Wed Apr  1 18:20:38 2020 us=841368 X.X.X.X:58811 Local Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,keydir 0,cipher BF-CBC,auth SHA1,keysize 128,tls-auth,key-method 2,tls-server'
    Wed Apr  1 18:20:38 2020 us=841385 X.X.X.X:58811 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,keydir 1,cipher BF-CBC,auth SHA1,keysize 128,tls-auth,key-method 2,tls-client'
    Wed Apr  1 18:20:38 2020 us=841423 X.X.X.X:58811 Local Options hash (VER=V4): '6c76e362'
    Wed Apr  1 18:20:38 2020 us=841440 X.X.X.X:58811 Expected Remote Options hash (VER=V4): '2a06964e'
    RWed Apr  1 18:20:38 2020 us=841479 X.X.X.X:58811 TLS: Initial packet from [AF_INET]X.X.X.X:58811, sid=07269695 2a159032
    WRRWRWWWRRRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWRWed Apr  1 18:20:41 2020 us=388913 X.X.X.X:58811 VERIFY OK: depth=1, CN=Easy-RSA CA
    Wed Apr  1 18:20:41 2020 us=389121 X.X.X.X:58811 VERIFY OK: depth=0, CN=client1
    WRWRWRWRWRWRWRWRWRWed Apr  1 18:20:41 2020 us=589321 X.X.X.X:58811 NOTE: Options consistency check may be skewed by version differences
    Wed Apr  1 18:20:41 2020 us=589371 X.X.X.X:58811 WARNING: 'version' is used inconsistently, local='version V4', remote='version V0 UNDEF'
    Wed Apr  1 18:20:41 2020 us=589395 X.X.X.X:58811 WARNING: 'dev-type' is present in local config but missing in remote config, local='dev-type tun'
    Wed Apr  1 18:20:41 2020 us=589445 X.X.X.X:58811 WARNING: 'link-mtu' is present in local config but missing in remote config, local='link-mtu 1542'
    Wed Apr  1 18:20:41 2020 us=589462 X.X.X.X:58811 WARNING: 'tun-mtu' is present in local config but missing in remote config, local='tun-mtu 1500'
    Wed Apr  1 18:20:41 2020 us=589495 X.X.X.X:58811 WARNING: 'comp-lzo' is present in local config but missing in remote config, local='comp-lzo'
    Wed Apr  1 18:20:41 2020 us=589528 X.X.X.X:58811 WARNING: 'keydir' is present in local config but missing in remote config, local='keydir 1'
    Wed Apr  1 18:20:41 2020 us=589545 X.X.X.X:58811 WARNING: 'cipher' is present in local config but missing in remote config, local='cipher BF-CBC'
    Wed Apr  1 18:20:41 2020 us=589562 X.X.X.X:58811 WARNING: 'auth' is present in local config but missing in remote config, local='auth SHA1'
    Wed Apr  1 18:20:41 2020 us=589578 X.X.X.X:58811 WARNING: 'keysize' is present in local config but missing in remote config, local='keysize 128'
    Wed Apr  1 18:20:41 2020 us=589592 X.X.X.X:58811 NOTE: --mute triggered...
    Wed Apr  1 18:20:41 2020 us=589779 X.X.X.X:58811 3 variation(s) on previous 10 message(s) suppressed by --mute
    Wed Apr  1 18:20:41 2020 us=589800 X.X.X.X:58811 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
    Wed Apr  1 18:20:41 2020 us=589817 X.X.X.X:58811 WARNING: this cipher's block size is less than 128 bit (64 bit).  Consider using a --cipher with a larger block size.
    Wed Apr  1 18:20:41 2020 us=589841 X.X.X.X:58811 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed Apr  1 18:20:41 2020 us=589897 X.X.X.X:58811 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
    Wed Apr  1 18:20:41 2020 us=589915 X.X.X.X:58811 WARNING: this cipher's block size is less than 128 bit (64 bit).  Consider using a --cipher with a larger block size.
    Wed Apr  1 18:20:41 2020 us=589933 X.X.X.X:58811 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    WRWed Apr  1 18:20:41 2020 us=654386 X.X.X.X:58811 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
    Wed Apr  1 18:20:41 2020 us=654474 X.X.X.X:58811 [client1] Peer Connection Initiated with [AF_INET]X.X.X.X:58811
    Wed Apr  1 18:20:41 2020 us=654542 client1/X.X.X.X:58811 MULTI_sva: pool returned IPv4=10.8.0.6, IPv6=(Not enabled)
    Wed Apr  1 18:20:41 2020 us=654612 client1/X.X.X.X:58811 MULTI: Learn: 10.8.0.6 -> client1/X.X.X.X:58811
    Wed Apr  1 18:20:41 2020 us=654657 client1/X.X.X.X:58811 MULTI: primary virtual IP for client1/X.X.X.X:58811: 10.8.0.6
    RWed Apr  1 18:20:44 2020 us=4168 client1/X.X.X.X:58811 PUSH: Received control message: 'PUSH_REQUEST'
    Wed Apr  1 18:20:44 2020 us=4203 client1/X.X.X.X:58811 send_push_reply(): safe_cap=940
    Wed Apr  1 18:20:44 2020 us=4232 client1/X.X.X.X:58811 SENT CONTROL [client1]: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,route 10.8.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5' (status=1)
    WWRRWRWWRWRWRRWWRWWWWWWW

Post Reply