Enter Auth Username/Password/Lubuntu 18.04

This forum is for general conversation and user-user networking.
Post Reply
crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 12:27 am

Hey guys,

Ever since I last updated OpenVPN about a month or two ago I keep getting a "enter auth username/password" box that pops up when my computer is booting up. It never used to do it until the update. My computer will still boot up without me entering anything in the box, but it takes a lot longer to boot up than it used to. I do not want openVPN starting upon booting. I always activate via terminal and would like it to stay that way.

I'm using OpenVPN with Perfect Privacy if that makes any difference.

I've also used the search field in this forum with no luck on the subject, so any help would be appreciated.

thanks,

Carl

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 6690
Joined: Fri Jun 03, 2016 1:17 pm

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by TinCanTech » Thu Mar 05, 2020 12:55 am


crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 1:07 am

Ok, well that doesn't help me much. I think that is for WIndows but, I am using Lubuntu 18.04 like mentioned in the title. I'm somewhat new to Linux systems so I was kind of looking for a mini tutorial or something along those lines.

TiTex
OpenVPN Super User
Posts: 304
Joined: Tue Apr 12, 2011 6:22 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by TiTex » Thu Mar 05, 2020 6:08 am

maybe you have the service enabled on your system
check with

Code: Select all

# check what system services you have that contain vpn in them , and take a note of them
sudo systemctl -a | grep -i vpn

# the same as above but for user services
systemctl --user -a | grep -i vpn

# disable them with 
sudo systemctl disable <service-name>
# or
sudo systemctl --user disable <service-name>
there's also this GUI that cand manage systemd services
https://oguzhaninan.github.io/Stacer-Web/

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 6690
Joined: Fri Jun 03, 2016 1:17 pm

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by TinCanTech » Thu Mar 05, 2020 12:55 pm

Sorry, I missed that this was not Windows.

crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 12:57 pm

TiTex wrote:
Thu Mar 05, 2020 6:08 am
maybe you have the service enabled on your system
check with

Code: Select all

# check what system services you have that contain vpn in them , and take a note of them
sudo systemctl -a | grep -i vpn

# the same as above but for user services
systemctl --user -a | grep -i vpn

# disable them with 
sudo systemctl disable <service-name>
# or
sudo systemctl --user disable <service-name>
there's also this GUI that cand manage systemd services
https://oguzhaninan.github.io/Stacer-Web/
When I run that first command, what am I looking for? I just get a list of all the VPN connections available through Perfect Privacy. Example below:

VPN connection to Amsterdam
openvpn@Basel.service loaded activating start start Open
VPN connection to Basel
openvpn@Belgrade.service loaded activating start start Open
VPN connection to Belgrade
openvpn@Berlin.service loaded activating start start Open
VPN connection to Berlin


Is there not a command that can just stop OpenVpn from starting upon booting the computer up? I never once had this issue until I did the last update. And I don't want to disable my VPN permanently, I still want to use it, just activate when I want to through the terminal. I need a little more clarification before I run a command and possible mess a whole bunch of shit up. I don't want to have to reinstall the OS, just not an option. Thanks in advance.

TiTex
OpenVPN Super User
Posts: 304
Joined: Tue Apr 12, 2011 6:22 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by TiTex » Thu Mar 05, 2020 3:57 pm

those are the services :)
you can stop/disable them like so
systemctl disable --now openvpn@Basel

crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 5:16 pm

TiTex wrote:
Thu Mar 05, 2020 3:57 pm
those are the services :)
you can stop/disable them like so
systemctl disable --now openvpn@Basel
Ok, so I have to go and do that for everyone of the Country/City connections manually? There are like 40 of them.

And do I also need to add .service after Basel in your example above?

Just a little confused. I'm not completely familiar with Linux yet.

User avatar
Pippin
Forum Team
Posts: 718
Joined: Wed Jul 01, 2015 8:03 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by Pippin » Thu Mar 05, 2020 5:19 pm

crhodes wrote:
Thu Mar 05, 2020 5:16 pm
And do I also need to add .service after Basel in your example above?
Nope, please see here:
https://github.com/OpenVPN/openvpn/blob ... ME.systemd

crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 5:23 pm

TiTex wrote:
Thu Mar 05, 2020 3:57 pm
those are the services :)
you can stop/disable them like so
systemctl disable --now openvpn@Basel
Nevermind. Just tried that and it doesn't work.

When I type that command ( systemctl disable --now openvpn@Basel ), it asks for my "auth password" again, which I never set up and do not know. I found a thread on Lubuntu forums recommending the same thing as you, but its not the correct fix because its still asking for the "auth password."

No one seems to have an answer which is kind of mind boggling to me. I can't believe no one else has experienced this issue. Guess I'm just stuck waiting 10 min every time for my damn computer to boot up, which only used to take 1 min max. Very discouraging to say the least.

crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 5:43 pm

Pippin wrote:
Thu Mar 05, 2020 5:19 pm
crhodes wrote:
Thu Mar 05, 2020 5:16 pm
And do I also need to add .service after Basel in your example above?
Nope, please see here:
https://github.com/OpenVPN/openvpn/blob ... ME.systemd
I don't even know where to begin with that truthfully. It's like a foreign language to me.

Like what command do I start off with and such?

Here below is an example of the command I use to start my OpenVpn connection if that helps at all.

openvpn /etc/openvpn/Miami.conf

User avatar
Pippin
Forum Team
Posts: 718
Joined: Wed Jul 01, 2015 8:03 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by Pippin » Thu Mar 05, 2020 6:03 pm

I think this will work to disable them all at once,

Code: Select all

systemctl disable openvpn-client@*
Otherwise one by one,

Code: Select all

systemctl disable openvpn-client@Miami

crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 6:31 pm

Pippin wrote:
Thu Mar 05, 2020 6:03 pm
I think this will work to disable them all at once,

Code: Select all

systemctl disable openvpn-client@*
Otherwise one by one,

Code: Select all

systemctl disable openvpn-client@Miami
No luck with those commands. There is no working or anything when I enter those commands. Do I need to be in a certain folder for those commands to work? I am under -sudo already.

Still when I start my computer up, during the Lubuntu boot up screen there is still that damn "Enter Auth Password" box at the bottom, and still taking about 10 min to boot up.

User avatar
Pippin
Forum Team
Posts: 718
Joined: Wed Jul 01, 2015 8:03 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by Pippin » Thu Mar 05, 2020 6:40 pm

What gives,

Code: Select all

systemctl status openvpn-client@*
?

crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Thu Mar 05, 2020 6:47 pm

Pippin wrote:
Thu Mar 05, 2020 6:40 pm
What gives,

Code: Select all

systemctl status openvpn-client@*
?
When I enter that command too, nothing happens. No working or anything at all.

crhodes
OpenVpn Newbie
Posts: 9
Joined: Thu Mar 05, 2020 12:17 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by crhodes » Wed Mar 11, 2020 1:46 pm

Any new finds on this? Still no luck on my end.

TiTex
OpenVPN Super User
Posts: 304
Joined: Tue Apr 12, 2011 6:22 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by TiTex » Wed Mar 11, 2020 5:20 pm

are you sure the prompt is coming from openvpn and not something else?

you can use this command to check which services are started and how long does it take
https://www.freedesktop.org/software/sy ... alyze.html

johnmorganhere
OpenVpn Newbie
Posts: 1
Joined: Fri Mar 13, 2020 10:36 am

Re: Enter Auth Username/Password/Lubuntu 18.04

Post by johnmorganhere » Tue Mar 17, 2020 1:34 pm

Hi there, I am new to OpenVPN. Interesting thread, thanks for the information.

Post Reply