Need some help with configuring my VPN server.

This forum is for general conversation and user-user networking.
Post Reply
Luksenburg00
OpenVpn Newbie
Posts: 3
Joined: Mon Aug 05, 2019 9:42 pm

Need some help with configuring my VPN server.

Post by Luksenburg00 » Mon Aug 05, 2019 9:45 pm

I am getting this error in my .log file when trying to connect my OVPN GUI "Options error: --pull-filter cannot be used with --mode server
Use --help for more information."

I cant see it saying pull filter or mode server anywhere in my Server.ovpn configuration file.

This is my config.
dev-node "ServerVPN"
mode server
port 12345

proto tcp4-server
dev tun

tls-server
tls-auth "C:\\Program Files\\OpenVPN\\config\\ta.key" 0

tun-mtu 1500
tun-mtu-extra 32
mssfix 1450

ca "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\ServerVPN.crt"
key "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\ServerVPN.key"
dh "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\dh4096.pem"

server 10.10.10.0 255.255.255.0

client-to-client
keepalive 10 120
cipher AES-128-CBC
comp-lzo

persist-key
persist-tun

client-config-dir "C:\\Program Files\\OpenVPN\\config"

verb 3

route-delay 5
route-method exe

push "route 192.168.1.1 255.255.255.0"
route 192.168.182.0 255.255.255.0




And since im a noob at this im following a youtube tutorial. It's this one. https://www.youtube.com/watch?v=hKfHwQgAsUo&t=801s

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 6035
Joined: Fri Jun 03, 2016 1:17 pm

Re: Need some help with configuring my VPN server.

Post by TinCanTech » Mon Aug 05, 2019 10:32 pm

Luksenburg00 wrote:
Mon Aug 05, 2019 9:45 pm
OVPN GUI "Options error: --pull-filter cannot be used with --mode server
Use --help for more information."
This is an unfortunate bug:
https://github.com/OpenVPN/openvpn-gui/issues/293

You can either use the command line to launch your server or the Openvpn Windows Service.
Not the Openvpn Interactive service, which is only for use with the openvpn-GUI.

Luksenburg00
OpenVpn Newbie
Posts: 3
Joined: Mon Aug 05, 2019 9:42 pm

Re: Need some help with configuring my VPN server.

Post by Luksenburg00 » Mon Aug 05, 2019 10:42 pm

TinCanTech wrote:
Mon Aug 05, 2019 10:32 pm
Luksenburg00 wrote:
Mon Aug 05, 2019 9:45 pm
OVPN GUI "Options error: --pull-filter cannot be used with --mode server
Use --help for more information."
This is an unfortunate bug:
https://github.com/OpenVPN/openvpn-gui/issues/293

You can either use the command line to launch your server or the Openvpn Windows Service.
Not the Openvpn Interactive service, which is only for use with the openvpn-GUI.
Okay, how do i start it with the command line? /Lukas

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 6035
Joined: Fri Jun 03, 2016 1:17 pm

Re: Need some help with configuring my VPN server.

Post by TinCanTech » Tue Aug 06, 2019 12:08 am

Luksenburg00 wrote:
Mon Aug 05, 2019 10:42 pm
how do i start it with the command line?
The normal way ..

Luksenburg00
OpenVpn Newbie
Posts: 3
Joined: Mon Aug 05, 2019 9:42 pm

Re: Need some help with configuring my VPN server.

Post by Luksenburg00 » Tue Aug 06, 2019 10:58 am

TinCanTech wrote:
Tue Aug 06, 2019 12:08 am
Luksenburg00 wrote:
Mon Aug 05, 2019 10:42 pm
how do i start it with the command line?
The normal way ..
What command?

Post Reply