Page 1 of 1

Unable to use OpenVPN

Posted: Mon Jun 03, 2019 2:48 pm
by kRel
Good morning to all and well found :) This is my first msg, a request for help. I hope to write in the correct section.

For months, until last month, OpenVPN worked perfectly.

My internet provider Fastweb, which has always provided me with a static public IP, (with which OpenVPN has always worked perfectly) for a month, has connected the GPON fiber optic to my home and my public static IP has changed.

From that day, despite having updated the new static public IP in the OpenVPN configuration, I can no longer access the internet via OpenVPN.

I use OpenVPN via my Synology NAS (DS918+) with the configuration as shown in the image - configuration that has always worked well.

Even using the "Export Configuration" function and applying the configuration to other machines, the VPN connection no longer works.

Could you help me please?

Greetings.

This is my SynologyNAS OpenVPN configuration:

Image

This is the log:
Mon Jun 03 11:23:28 2019 OpenVPN 2.4.6 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 26 2018
Mon Jun 03 11:23:28 2019 Windows version 6.2 (Windows 8 or greater) 64bit
Mon Jun 03 11:23:28 2019 library versions: OpenSSL 1.1.0h 27 Mar 2018, LZO 2.10
Mon Jun 03 11:23:38 2019 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Mon Jun 03 11:23:38 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]XXX.XXX.1XX.37:1194
Mon Jun 03 11:23:38 2019 UDP link local (bound): [AF_INET][undef]:1194
Mon Jun 03 11:23:38 2019 UDP link remote: [AF_INET]XXX.XXX.1XX.37:1194
Mon Jun 03 11:24:38 2019 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jun 03 11:24:38 2019 TLS Error: TLS handshake failed
Mon Jun 03 11:24:38 2019 SIGUSR1[soft,tls-error] received, process restarting
Mon Jun 03 11:24:43 2019 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Mon Jun 03 11:24:43 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]XXX.XXX.1XX.37:1194
Mon Jun 03 11:24:43 2019 UDP link local (bound): [AF_INET][undef]:1194
Mon Jun 03 11:24:43 2019 UDP link remote: [AF_INET]XXX.XXX.1XX.37:1194
questa invece รจ la configurazione:
dev tun
tls-client

remote XXX.XXX.1XX.37 1194

# The "float" tells OpenVPN to accept authenticated packets from any address,
# not only the address which was specified in the --remote option.
# This is useful when you are connecting to a peer which holds a dynamic address
# such as a dial-in user or DHCP client.
# (Please refer to the manual of OpenVPN for more information.)

#float

# If redirect-gateway is enabled, the client will redirect it's
# default network gateway through the VPN.
# It means the VPN connection will firstly connect to the VPN Server
# and then to the internet.
# (Please refer to the manual of OpenVPN for more information.)

#redirect-gateway def1

# dhcp-option DNS: To set primary domain name server address.
# Repeat this option to set secondary DNS server addresses.

#dhcp-option DNS DNS_IP_ADDRESS

pull

# If you want to connect by Server's IPv6 address, you should use
# "proto udp6" in UDP mode or "proto tcp6-client" in TCP mode
proto udp

script-security 2


comp-lzo

reneg-sec 0

cipher AES-256-CBC

auth SHA512

auth-user-pass
<ca>
-----BEGIN CERTIFICATE-----
MII
**************************
**************************
g==
-----END CERTIFICATE-----

</ca>

Re: Unable to use OpenVPN

Posted: Mon Jun 03, 2019 6:35 pm
by kRel
solved . . . . .

Re: Unable to use OpenVPN

Posted: Thu Aug 08, 2019 2:30 pm
by aburns
How did you solve this? I have the same problem.