mwan3- 2nd wan connection goes offline when the first wan is removed

This forum is for general conversation and user-user networking.
Post Reply
tamilmad
OpenVpn Newbie
Posts: 5
Joined: Tue Apr 30, 2019 4:47 am

mwan3- 2nd wan connection goes offline when the first wan is removed

Post by tamilmad » Fri May 03, 2019 9:50 am

I have installed openwrt 18.06 on ASUS RT-AC58U. My main main WAN interface is through Fibre optic cable from my ISP connected to the router. I wanted to have a back up WAN through my Mobile data through USB Tethering as a backup if my cable connection fail.

The first main interface is wan and the USB tethered interface is wan2. On the interface tab of Lua GUI both show connected and working. In the the load sharing tab also it say as online and I am able to ping google.com from both the interfaces both from lua GUI and from commend terminal of the openwrt. Internet also works well.

The configuraion details of mwan3 are as below.

config globals 'globals'
option mmx_mask '0x3F00'
option local_source 'lan'

config interface 'wan'
option enabled '1'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'
option family 'ipv4'
option reliability '2'
option count '1'
option timeout '2'
option failure_latency '1000'
option recovery_latency '500'
option failure_loss '20'
option recovery_loss '5'
option interval '5'
option down '3'
option up '8'

config member 'wan_m1_w3'
option interface 'wan'
option metric '1'
option weight '3'

config member 'wan_m2_w3'
option interface 'wan'
option metric '2'
option weight '3'

config member 'wan2_m1_w2'
option metric '1'
option weight '2'
option interface 'wan2'
config member 'wan2_m2_w2'
option metric '2'
option weight '2'
option interface 'wan2'

config member 'wan6_m1_w3'
option interface 'wan6'
option metric '1'
option weight '3'

config member 'wan6_m2_w3'
option interface 'wan6'
option metric '2'
option weight '3'

config member 'wanb6_m1_w2'
option interface 'wanb6'
option metric '1'
option weight '2'

config member 'wanb6_m2_w2'
option interface 'wanb6'
option metric '2'
option weight '2'

config policy 'wan_only'
list use_member 'wan_m1_w3'
list use_member 'wan6_m1_w3'
option last_resort 'default'

config policy 'wan2_only'
list use_member 'wan2_m1_w2'
list use_member 'wanb6_m1_w2'
option last_resort 'default'
config policy 'balanced'
list use_member 'wan_m1_w3'
list use_member 'wan2_m1_w2'
list use_member 'wan6_m1_w3'
list use_member 'wanb6_m1_w2'
option last_resort 'default'

config policy 'wan_wan2'
list use_member 'wan_m1_w3'
list use_member 'wan2_m2_w2'
list use_member 'wan6_m1_w3'
list use_member 'wanb6_m2_w2'
option last_resort 'default'

config policy 'wan2_wan'
list use_member 'wan_m2_w3'
list use_member 'wan2_m1_w2'
list use_member 'wan6_m2_w3'
list use_member 'wanb6_m1_w2'
option last_resort 'default'

config rule 'https'
option sticky '1'
option dest_port '443'
option proto 'tcp'
option use_policy 'wan_wan2'

config rule 'default_rule'
option dest_ip '0.0.0.0/0'
option proto 'all'
option sticky '0'
option use_policy 'wan_wan2'
config rule 'default_rule'
option dest_ip '0.0.0.0/0'
option proto 'all'
option sticky '0'
option use_policy 'wan_wan2'

config interface 'wan2'
option enabled '1'
option family 'ipv4'
option track_method 'ping'
option reliability '1'
option count '1'
option size '56'
option check_quality '0'
option timeout '2'
option interval '5'
option failure_interval '5'
option recovery_interval '5'
option down '3'
option up '3'
option flush_conntrack 'never'
option initial_state 'offline'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'

config rule 'http'
option dest_port '80'
option proto 'all'
option sticky '1'
option use_policy 'wan_wan2'

But when I physically remove the main interface (wan) to check the backup wan2 (USB Tethered), on the interface tab of Lua GUI wan shows as disconnected and wan2 shows as connected. However, in the the load sharing tab it displays both as offline and internet does not work. When I reconnect the cable both becomes online.

Can someone help in this matter.

Post Reply