OpenVPN 2.1 requires '--script-security 2

This forum is for general conversation and user-user networking.
Post Reply
chrisguk
OpenVpn Newbie
Posts: 2
Joined: Tue Jun 26, 2012 2:31 pm

OpenVPN 2.1 requires '--script-security 2

Post by chrisguk » Tue Jun 26, 2012 2:35 pm

Hi there,

I have my pass and user in a file called pass.txt but in openvpn 2.2 a pop up wiindow keeps asking for my password. Also it displays the following in the log:

Tue Jun 26 16:34:13 2012 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

How can I fix this?

User avatar
janjust
Forum Team
Posts: 2703
Joined: Fri Aug 20, 2010 2:57 pm
Location: Amsterdam
Contact:

Re: OpenVPN 2.1 requires '--script-security 2

Post by janjust » Tue Jun 26, 2012 2:49 pm

the warning is harmless.
whether you can store your username+password in a file depends on how openvpn was compiled.
If it was NOT enabled you'd see a message similar to

Code: Select all

Sorry, '%s' password cannot be read from a file
if it was enabled then there's something wrong with your config.

chrisguk
OpenVpn Newbie
Posts: 2
Joined: Tue Jun 26, 2012 2:31 pm

Re: OpenVPN 2.1 requires '--script-security 2

Post by chrisguk » Tue Jun 26, 2012 3:25 pm

This is my config file:

Code: Select all

client

ping 5
ping-exit 30
dev tap
fast-io
proto udp

remote 9**.***.***.** 443

resolv-retry infinite
nobind
persist-key
persist-tun

mute-replay-warnings

ca ca.crt
cert vpn.crt
key vpn.key

reneg-sec 0

ns-cert-type server

--auth-user-pass pass.txt
 
verb 3

User avatar
janjust
Forum Team
Posts: 2703
Joined: Fri Aug 20, 2010 2:57 pm
Location: Amsterdam
Contact:

Re: OpenVPN 2.1 requires '--script-security 2

Post by janjust » Wed Jun 27, 2012 6:54 am

remove the dashes in front of auth-user-pass

add 'verb 6' to the client log and connect - do you see anything about 'caching passwords'?

Post Reply