Some websites don't open while OpenVPN connection is active

This forum is for general conversation and user-user networking.
Post Reply
Jack125
OpenVpn Newbie
Posts: 3
Joined: Wed Sep 16, 2020 11:35 am

Some websites don't open while OpenVPN connection is active

Post by Jack125 » Wed Sep 16, 2020 11:44 am

I have a VPN connection on my home computer to my remote working computer, but when connection is open, I can't visit some websites on my home computer. However, online services for an IP address detection show the same IP address whether the connection is open or not.
Why does it happen and how to solve this trouble?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7812
Joined: Fri Jun 03, 2016 1:17 pm

Re: Some websites don't open while OpenVPN connection is active

Post by TinCanTech » Wed Sep 16, 2020 12:14 pm

Could be many reasons ..

viewtopic.php?f=30&t=22603

Jack125
OpenVpn Newbie
Posts: 3
Joined: Wed Sep 16, 2020 11:35 am

Re: Some websites don't open while OpenVPN connection is active

Post by Jack125 » Wed Sep 16, 2020 12:40 pm

I read this, but haven't yet understood what to do with this information. My OpenVPN version is shown as 2.4.9-I601-Win10, and I don't know whether it is Access Server or Community Edition. However, I'm not a system administrator and may not understand a lot of terms :)
I can create this topic in other subforum if the current is not right for this, or provide some logs/configs needed

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7812
Joined: Fri Jun 03, 2016 1:17 pm

Re: Some websites don't open while OpenVPN connection is active

Post by TinCanTech » Wed Sep 16, 2020 5:00 pm

Read it again and again .. and try following some of the links and read them too.

Basically, you will find that OpenVPN is working fine but some websites don't work.

Probably, those websites are detecting you are using a VPN and are therefore blocking you.

I would consider not using websites that are so rude and intrusive ..

But if you manage to figure the following things out then add them to this thread:
  • Your server and client operating system
  • Your server and client version of OpenVPN
  • Your server and client configuration files in use
  • Your server and client log files
  • How to use copy/paste text
To save you some time, try using --block-outside-dns.
See the manual/howto for details.

Jack125
OpenVpn Newbie
Posts: 3
Joined: Wed Sep 16, 2020 11:35 am

Re: Some websites don't open while OpenVPN connection is active

Post by Jack125 » Wed Sep 16, 2020 6:25 pm

I don't have information about the server because it is a server of my company and I don't have access to it.
About my computer:
- Operating system: Windows 10
- OpenVPN version: 2.4.9-I601-Win10

Configuration file .ovpn:
Client config
dev tun
proto tcp
keepalive 5 30
port 1194
client
resolv-retry infinite
auth SHA1
tun-mtu 12000
fragment 0
mssfix 0
auth-nocache
remote-cert-tls server
cipher AES-256-CBC
persist-key
persist-tun

There are also "remote" and "pkcs12" fields, but I'm afraid to show them because they include some confidential information.

log file:

Code: Select all

Wed Sep 16 20:52:40 2020 OpenVPN 2.4.9 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 16 2020
Wed Sep 16 20:52:40 2020 Windows version 6.2 (Windows 8 or greater) 64bit
Wed Sep 16 20:52:40 2020 library versions: OpenSSL 1.1.1f  31 Mar 2020, LZO 2.10
Enter Management Password:
Wed Sep 16 20:52:41 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]<some address>:1194
Wed Sep 16 20:52:41 2020 Attempting to establish TCP connection with [AF_INET]<some address>:1194 [nonblock]
Wed Sep 16 20:52:42 2020 TCP connection established with [AF_INET]<some address>:1194
Wed Sep 16 20:52:42 2020 TCP_CLIENT link local: (not bound)
Wed Sep 16 20:52:42 2020 TCP_CLIENT link remote: [AF_INET]<some address>:1194
Wed Sep 16 20:52:42 2020 [frame.iss.ru] Peer Connection Initiated with [AF_INET]<some address>:1194
Wed Sep 16 20:52:43 2020 open_tun
Wed Sep 16 20:52:43 2020 TAP-WIN32 device [Подключение по локальной сети] opened: \\.\Global\{DA0F00B6-A930-41AE-8977-DA4B47E55F8A}.tap
Wed Sep 16 20:52:43 2020 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.10.101.194/255.255.255.252 on interface {DA0F00B6-A930-41AE-8977-DA4B47E55F8A} [DHCP-serv: 10.10.101.193, lease-time: 31536000]
Wed Sep 16 20:52:43 2020 Successful ARP Flush on interface [14] {DA0F00B6-A930-41AE-8977-DA4B47E55F8A}
Wed Sep 16 20:52:43 2020 Block_DNS: WFP engine opened
Wed Sep 16 20:52:43 2020 Block_DNS: Added a persistent sublayer with pre-defined UUID
Wed Sep 16 20:52:43 2020 Block_DNS: Added permit filters for exe_path
Wed Sep 16 20:52:43 2020 Block_DNS: Added block filters for all interfaces
Wed Sep 16 20:52:43 2020 Block_DNS: Added permit filters for TAP interface
Wed Sep 16 20:52:48 2020 Initialization Sequence Completed
I tried to add "block-outside-dns" to the config file, but it didn't help :(
Last edited by Pippin on Wed Sep 16, 2020 6:29 pm, edited 1 time in total.
Reason: Formatting

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7812
Joined: Fri Jun 03, 2016 1:17 pm

Re: Some websites don't open while OpenVPN connection is active

Post by TinCanTech » Wed Sep 16, 2020 8:34 pm

Jack125 wrote:
Wed Sep 16, 2020 6:25 pm
I don't have information about the server because it is a server of my company and I don't have access to it
Speak to the people that do.

If that is not an option for you then I am available for hire.

Post Reply