openvpn3 linux client ignores the lport directive

This forum is for general conversation and user-user networking.
Post Reply
bohemian
OpenVpn Newbie
Posts: 1
Joined: Fri Oct 22, 2021 9:48 pm

openvpn3 linux client ignores the lport directive

Post by bohemian » Fri Oct 22, 2021 10:02 pm

I have successfully installed openvpn3 linux client debian package on my ubuntu bionic desktop. I am using a config that has an lport directive which I have to use to make a successful connection but when I invoke openvpn3 with that config the lport directive is ignored. See log below, it shows the lport directive as being unused and while connecting it uses lport of 53191 instead of the one I specified 58137.

2021-10-22 17:55:47 Client DEBUG: UNUSED OPTIONS
4 [resolv-retry] [infinite]
5 [lport] [58137]
10 [verb] [3]
2021-10-22 17:55:47 Client VERB2: Resolving
2021-10-22 17:55:47 Client DEBUG: Contacting 173.66.98.131:53191 via UDP
2021-10-22 17:55:47 Client VERB1: Waiting for server response
2021-10-22 17:55:47 Client DEBUG: Connecting to [173.66.98.131]:53191 (173.66.98.131) via UDPv4

I have tried invoking openvpn3 with sudo access and the behavior is still the same, lport is ignored.

Note that if I use the regular openvpn v2.4.4 and invoke it with sudo access then the lport directive is honored and the connection succeeds. Anyone have any idea why the new and improved latest version of openvpn ignores the lport directive? Is there a way to make it honor the lport directive?

User avatar
TinCanTech
Forum Team
Posts: 9982
Joined: Fri Jun 03, 2016 1:17 pm

Re: openvpn3 linux client ignores the lport directive

Post by TinCanTech » Fri Oct 22, 2021 10:11 pm

Yes, it is ignored.

Post Reply