Community Support Forum
 
  OpenVPN.net  •  Forum Index  •  FAQ  

It is currently Sat Apr 19, 2014 12:02 pm




Post new topic Reply to topic  [ 2 posts ] 
 TCP support is broken in iOS app 
Author Message
 Post subject: TCP support is broken in iOS app
PostPosted: Tue May 21, 2013 12:27 pm 
OpenVpn Newbie

Joined: Tue May 21, 2013 12:09 pm
Posts: 1
Hi everyone,

There's a rather annoying bug in the iOS app that causes packets sent from the server over the VPN tunnel to be dropped on the iOS device. This happens when using --proto tcp and when a packet is received on the iOS end within one or so second of establishing the connection.

This error is easy to reproduce. Ping the iOS device over the tunnel with a short interval (ping -i 0.2 10.0.8.x) and then connect (or reconnect) using the iOS app. The tunnel will appear to be connected and the counters on the client will also tick, but any traffic sent over the VPN is dropped.

I've verified this behaviour on several devices running various versions of iOS 6, including the latest 6.1.3. This bug affects the OpenVPN connect version that was released today and also the initial version.


Offline
 Profile  
 
 Post subject: Re: TCP support is broken in iOS app
PostPosted: Wed May 22, 2013 5:40 am 
OpenVPN Technologies

Joined: Thu Jan 24, 2013 12:13 am
Posts: 139
Thanks -- we've confirmed this as a bug. It will be fixed in the next release of the iOS client (1.0.2).

James


Offline
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


 Who is online 

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  


phpBB SEO
[ Time : 0.388s | 14 Queries | GZIP : On ]

 
Index  |  FAQ


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group