OpenVPN Server at home: no internet access IP_Forwarding

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See https://forums.openvpn.net/viewtopic.php?f=30&t=21589 for an example.
Flobesst
OpenVpn Newbie
Posts: 2
Joined: Mon Oct 06, 2014 1:45 pm

OpenVPN Server at home: no internet access IP_Forwarding

Postby Flobesst » Mon Oct 06, 2014 2:05 pm

Hi all,

I'm a brand new OpenVPN user so forgive my lack of knowledge :)

I'm currently having troubles with my home-made OpenVPN server. I'm running this server on a Windows 7 machine and my clients are one Windows 7 computer and an Android smartphone.

Clients can actually connect to the VPN but they are not connected to the Internet. Ping 8.8.8.8 doesn't work. I want all client's trafic (web included) to go through my VPN. Here is my server conf file:

Code: Select all

port 1723
proto tcp
dev tun
ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
server 10.10.10.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "redirect-gateway"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
keepalive 10 120
comp-lzo
persist-key
persist-tun
status openvpn-status.log
verb 3


My Windows 7 client conf:

Code: Select all

client
dev tun
proto tcp
remote *.*.94.6 1723
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert flo-17r.crt
key flo-17r.key
ns-cert-type server
comp-lzo
verb 3


On connection, my Windows 7 client get IP address 10.10.10.14 and is unable ton ping server on 10.10.10.1 and doesn't have Internet access at all.

Tell me if you need more information and thanks for your help :)
Last edited by debbie10t on Tue Oct 07, 2014 11:58 am, edited 2 times in total.
Reason: Privacy / Title

User avatar
Traffic
OpenVPN Protagonist
Posts: 4081
Joined: Sat Aug 09, 2014 11:24 am

Re: OpenVPN Server at home: no internet access

Postby Traffic » Mon Oct 06, 2014 6:13 pm

Flobesst wrote:my Windows 7 client get IP address 10.10.10.14 and is unable ton ping server on 10.10.10.1
That sounds like a firewall problem ..

Also, did you enable IP Forwarding on your server ?

Flobesst
OpenVpn Newbie
Posts: 2
Joined: Mon Oct 06, 2014 1:45 pm

Re: OpenVPN Server at home: no internet access

Postby Flobesst » Mon Oct 06, 2014 7:19 pm

Traffic wrote:
Flobesst wrote:my Windows 7 client get IP address 10.10.10.14 and is unable ton ping server on 10.10.10.1
That sounds like a firewall problem ..

Also, did you enable IP Forwarding on your server ?

Well, you solved my problem with a single post :D My firewalls were both turned off but IP Forwarding wasn't enabled.

Just for people who are in the same case, you can follow this tutorial to activate IP Forwarding:
topic7806.html (check the end of the first post).

I also had a new error message on the server, saying that "netsh command failed returned error code 1". I just had to rename my TAP-Windows Adapter name to "VPN card" (or whatever you want) and the problem was gone.

Thx !


Return to “Configuration”

Who is online

Users browsing this forum: No registered users and 6 guests