TAP installer failed on Windows 10

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
hermy9
OpenVpn Newbie
Posts: 3
Joined: Sun Nov 27, 2016 1:50 pm

TAP installer failed on Windows 10

Postby hermy9 » Sun Nov 27, 2016 2:40 pm

Hi, I hope that I am at the right place.

Installing Openvpn 2.3.13 failed on win10 with this error message, after two successful installations on other win10 systems.

"An error occurred installing the TAP device driver."

Installing TAP separately fails with the same error message. In addition, the log shows this sequence at the end:

"Updating drivers for tap0901 from C:\Program Files\TAP-Windows\driver\OemVista.inf.
UpdateDriverForPlugAndPlayDevices failed, GetLastError = -536870330
tapinstall.exe failed.
tapinstall.exe returned: 2
tapinstall cumulative status: 2
Created uninstaller: C:\Program Files\TAP-Windows\Ininstall.exe
Completed"

What is going wrong here? What does the error code mean?

I tried several things:
- Openvpn connection to my external server is not possible
- Avira Services deactivated
- Windows firewall deactivated
- reboot

The error code cannot be found with Google.

Hermy9

User avatar
TinCanTech
I should be on the dev team.
Posts: 1926
Joined: Fri Jun 03, 2016 1:17 pm

Re: TAP installer failed on Windows 10

Postby TinCanTech » Mon Nov 28, 2016 1:59 pm

Try:

<Right-click> "Add new TAP Virtual ethernet adapter" -> Run as administrator

hermy9
OpenVpn Newbie
Posts: 3
Joined: Sun Nov 27, 2016 1:50 pm

Re: TAP installer failed on Windows 10

Postby hermy9 » Mon Nov 28, 2016 10:18 pm

Done by starting C:\Program Files\TAP-Windows\bin\addtap.bat as administrator.
Same error message.

hermy9
OpenVpn Newbie
Posts: 3
Joined: Sun Nov 27, 2016 1:50 pm

Re: TAP installer failed on Windows 10

Postby hermy9 » Sun Dec 04, 2016 8:31 am

In the meantime, I spent hours and tried a lot of things, no success up to now.

I noted that the driver is not in windows registry. Based on
https://support.vpnsecure.me/articles/g ... ters-found
I see 13 entries in registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e972-e325-11ce-bfc1-08002be10318}\xxxx
where
xxxx = 0000 .... 0012

None of them can be attributed to TAP-Windows Adapter V9. I followed the instruction given by the link above (which is not very clear), with no success.
On my other win10 system, I see 17 entries, and entry 0015 can be attributed to the TAP driver. There, all works fine.

Other attempts (reboot, windows secure mode, clean registry with ccleaner ...) were unsuccessful as well.

So, my question is still the same. What is going wrong when installing the TAP driver?

Last lines of C:\Windows\INF\setupapi.dev.log follow here, after having done this:
- uninstalling TAP and Openvpn using uninstall.exe for both
- cleaning c:\Benutzer\Administrator\AppData\Local\Temp

...
ndv: Forcing driver install:
ndv: Inf Name - oemvista.inf
ndv: Driver Date - 04/21/2016
ndv: Driver Version - 9.0.0.21
sto: {Setup Import Driver Package: c:\program files\tap-windows\driver\oemvista.inf} 09:17:52.921
sto: Driver package already imported as 'oem121.inf'.
sto: {Setup Import Driver Package - exit (0x00000000)} 09:17:52.921
inf: Opened INF: 'c:\program files\tap-windows\driver\oemvista.inf' ([strings])
dvi: Searching for hardware ID(s):
dvi: tap0901
inf: Opened INF: 'C:\WINDOWS\System32\DriverStore\FileRepository\oemvista.inf_amd64_a572b7f20c402d28\oemvista.inf' ([strings])
dvi: Created Driver Node:
dvi: HardwareID - tap0901
dvi: InfName - C:\WINDOWS\System32\DriverStore\FileRepository\oemvista.inf_amd64_a572b7f20c402d28\oemvista.inf
dvi: DevDesc - TAP-Windows Adapter V9
dvi: DrvDesc - TAP-Windows Adapter V9
dvi: Provider - TAP-Windows Provider V9
dvi: Mfg - TAP-Windows Provider V9
dvi: ModelsSec - tap0901.NTamd64
dvi: InstallSec - tap0901.ndi
dvi: Section - tap0901.ndi
dvi: Rank - 0x00ff0000
dvi: Signer - OpenVPN Technologies, Inc.
dvi: Signer Score - Authenticode
dvi: DrvDate - 04/21/2016
dvi: Version - 9.0.0.21
dvi: Enumerating INFs from path list 'C:\WINDOWS\INF'
inf: Searched 1 potential matches in published INF directory
dvi: Selected driver installs from section [tap0901.ndi] in 'c:\windows\system32\driverstore\filerepository\oemvista.inf_amd64_a572b7f20c402d28\oemvista.inf'.
dvi: Class GUID of device changed to: {4d36e972-e325-11ce-bfc1-08002be10318}.
dvi: Set selected driver complete.
ump: Installation deferred (too early)
ump: Installation will be processed asynchronously
!!! ndv: Device install failed for device.
ndv: Installing NULL driver.
ump: Installation deferred (too early)
ump: Installation will be processed asynchronously
ndv: {Update Device Driver - exit(e0000246)}
!!! ndv: Failed to install device instance 'ROOT\NET\0000'. Error = 0xe0000246
<<< Section end 2016/12/04 09:17:52.967
<<< [Exit status: FAILURE(0xe0000246)]


Return to “Installation Help”

Who is online

Users browsing this forum: No registered users and 2 guests