Error with User in a Group

cala
OpenVpn Newbie
Posts: 2
Joined: Thu Jan 26, 2017 4:24 pm

Error with User in a Group

Postby cala » Thu Jan 26, 2017 4:53 pm

I have a single user that when assigned to a group with Admin privileges and given autologin permission, OpenVPN throws an error:

DynamicPool' object has no attribute 'range_render': omi/auth:546,internet/defer:746,sagent/usersvc:1295,sagent/usersvc:602,sagent/usersvc:145,sagent/usersvc:255,sagent/usersvc:216 (exceptions.AttributeError)" [None]


The user can contact the server and attempt to log in, and then gets the prompt for MFA, but is then denied due to the server error above.
I have looked around and can find nothing referring to it. No other user has gotten this error, the group assignment works, and when this user is assigned to another group, there are no issues. I have tried deleting and re-creating the user with no luck.
LDAP authentication and DUO MFA are set up on the server, but also are not creating issues.

OpenVPN_AS v. 2.1.4b
Tested with multiple client versions

Full auth log:
2017-01-25 16:03:04-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:04 2017 xxx.xxx.xxx.xxx:xx [user.name_AUTOLOGIN] Peer Connection Initiated with [AF_INET]192.168.1.81:57826'
2017-01-25 16:03:04-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:04 2017 xxx.xxx.xxx.xxx:xx Delayed exit in 5 seconds'
2017-01-25 16:03:04-0500 [-] OVPN 1 OUT: "Wed Jan 25 21:03:04 2017 xxx.xxx.xxx.xxx:xx SENT CONTROL [user.name_AUTOLOGIN]: 'AUTH_FAILED' (status=1)"
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx TLS: Initial packet from [AF_INET]xxx.xxx.xxx.xxx:xx, sid=451c2ebc 775ae3a5'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx VERIFY OK: depth=1, /CN=OpenVPN CA'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx VERIFY OK: nsCertType=CLIENT'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx VERIFY OK: depth=0, /CN=Shannon.Ramsay_AUTOLOGIN'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_GUI_VER=ovpnmi_1.0.0'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_VER=3.1.1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_PLAT=win'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_NCP=2'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_TCPNL=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_PROTO=2'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_LZO=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_LZO_SWAP=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_LZ4=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_LZ4v2=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_COMP_STUB=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_COMP_STUBv2=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_AUTO_SESS=1'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: UV_ASCLI_VER=UV_ASCLI_VER'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: UV_PLAT_REL=UV_PLAT_REL'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 xxx.xxx.xxx.xxx:xx peer info: IV_HWADDR=c8:5b:76:05:fd:ed'
2017-01-25 16:03:05-0500 [-] VPN Auth Failed: "'DynamicPool' object has no attribute 'range_render': omi/auth:546,internet/defer:746,sagent/usersvc:1295,sagent/usersvc:602,sagent/usersvc:145,sagent/usersvc:255,sagent/usersvc:216 (exceptions.AttributeError)" [None]
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 MANAGEMENT: CMD \'client-deny 1488 0 "AS auth failed"\''
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 MULTI: connection rejected: AS auth failed, CLI:[NULL]'
2017-01-25 16:03:05-0500 [-] OVPN 1 OUT: 'Wed Jan 25 21:03:05 2017 192.168.1.81:57827 Control Channel: TLSv1.2, cipher TLSv1/SSLv3 ECDHE-RSA-AES256-GCM-SHA384, 2048 bit RSA'


Any ideas how to fix?

cala
OpenVpn Newbie
Posts: 2
Joined: Thu Jan 26, 2017 4:24 pm

Re: Error with User in a Group

Postby cala » Fri Jan 27, 2017 4:57 pm

Had a new user that was getting the same error and was able to isolate and fix:

If the user is assigned a STATIC IP that is in the groups Dynamic range, the error occurs. I changed my Dynamic range for this group, and the users are now able to connect successfully.


Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 1 guest