Incorrect conversion TUN->TAP, server now has subnet mask IP

nuetron
OpenVpn Newbie
Posts: 1
Joined: Wed Apr 05, 2017 4:13 pm

Incorrect conversion TUN->TAP, server now has subnet mask IP

Postby nuetron » Wed Apr 05, 2017 4:35 pm

Hey Moderators, I'm not sure if this is the correct forum or not, please move if needed, thanks!

The issue:
I have a hosted virtual server in the cloud, and have only a few IPs allowed to connect to Webmin on the server. One way is the public IP at our house, and the other way is the subnet of the Open VPN net.
The virtual server is also the OpenVPN server, and it was set up originally as TUN. Since I wanted to convert it later to TAP, I had my guru brother give me a few instructions on doing so. However, this was a rare occasion that he was kinda buzzed and so he could not think very clearly, which caused some issues, such as the VPN server getting broken.
I did what I could to try to fix it, and it seemed to be working fine for a while, until I could not connect any more because my ovpn client stated the subnet was off (the client was configured for dev tun instead of dev tap). I didn't think much of it since I could still connect to webmin over the internet anyway, and let it be.
That is, until our public IP changed, and not just another IP on the same subnet, but our ISP changed the whole subnet.

So I try to connect to the server again to change something, and find that I can't because it's TAP instead of TUN. No biggie, just need to change the client config, right? Well, I was able to connect, but the network adapter states the subnet is 10.124.0.0/16 and the dhcp server is 10.124.0.0. Not funny.
ARP shows the server is indeed at 0.0 with a mac address listed.

TL;DR
My OpenVPN server is set up for TAP, and has the VPN subnet IP address 10.124.0.0/16 and I have no other way to connect to the server for management purposes because my public IP has changed and I have firewalled access from any other IP.

How can I connect to the server?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2420
Joined: Fri Jun 03, 2016 1:17 pm

Re: Incorrect conversion TUN->TAP, server now has subnet mask IP

Postby TinCanTech » Wed Apr 05, 2017 6:14 pm

nuetron wrote:Hey Moderators, I'm not sure if this is the correct forum or not, please move if needed, thanks!
Hey, read this and you decide.


Return to “Access Server”

Who is online

Users browsing this forum: No registered users and 2 guests