Tapinstall failed with custom DeviceDescription

How to customize and extend your OpenVPN installation.
SvenS
OpenVpn Newbie
Posts: 1
Joined: Mon Dec 01, 2014 10:05 am

Tapinstall failed with custom DeviceDescription

Postby SvenS » Mon Dec 01, 2014 10:24 am

Hello,
i write a custom Tap-Installer for my Win-App with a custom DeviceDescription in *.inf.
I change it from "TAP-Windows Adapter V9" to "MyDeviceName".
The install failed on a WinSvr2012 Standard with:

Code: Select all

Device node created. Install is completed...
Updating drivers for tap0901 from "C:\...\OemVista.inf"
UpdateDriverForPlugAndPlayDevices failed, GetLastError=-536870325
tapinstall.exe failed.

The install with original DeviceDescription is OK.
My old-install with 2.3.3 and new 2.3.5 is correct for XP, 2003, SBS2011, Win7.

Can I change the DeviceDescription in *.inf-Files?
New Policys for WinSvr2012?

Thanks for everyone’s help.

flaviudsi
OpenVpn Newbie
Posts: 1
Joined: Fri May 19, 2017 7:50 am

Re: Tapinstall failed with custom DeviceDescription

Postby flaviudsi » Fri May 19, 2017 7:54 am

Hi SvenS,

Were you able to find a solution for your issue? I am experience exactly the same problem.

I am also trying to customize the description of the TAP. I have edited the .inf file and renamed the .cat & .sys files.

Any idea what I am missing here? Could you please point me to the correct direction for the fix?

Thank you.
Flaviu :)


Return to “Scripting and Customizations”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests