Centos Linux/FreeBSD Cannot Forward br0 IP to tap0

This forum is for general conversation and user-user networking.
AreebSooYasir
OpenVpn Newbie
Posts: 4
Joined: Thu Aug 10, 2017 5:13 pm

Centos Linux/FreeBSD Cannot Forward br0 IP to tap0

Postby AreebSooYasir » Thu Aug 10, 2017 5:20 pm

Hello everyone I am having trouble getting my transparent bridge to work using tap (tap0 on both ends) to allow the remote hosts public IPs to be used on the client end LAN as if it were local.


Host A - br0 with tap0 added to the bridge
Client A - br0 with tap0 not added (though adding it to the bridge does not fix things)

Client A's job is put Host A's remote gateway on the Client A's LAN.

Host A's setup:
br0 96.54.22.56

Client A's setup:
br0 192.168.5.2
br0:0 96.54.22.1 (this is the default gateway that Host A uses).

Desired outcome.
LAN users on Client A's network should be able to assign a public IP from Host A's network.
eg. Client A other LAN user
eth0 96.54.22.100
gateway=96.54.22.1

I have tried two methods having both tap0's with 0.0.0.0 and also using IPs eg. 10.10.10.1 and 10.10.10.2 and saying forward traffic for 96.54.22.1 via 10.10.10.2 but this doesn't seem to work either.

The problem is that hosts can ping Client A's 96.54.22.1 but it stays local and doesn't appear iptables or the routing table can manipulate it and never appears to forward any of that traffic to the tunnel.

Does anyone have the solution for this situation?

Thanks!

Return to “Off Topic, Related”

Who is online

Users browsing this forum: No registered users and 5 guests