OpenVPN works for seconds only

This forum is for general conversation and user-user networking.
AllaPugna
OpenVpn Newbie
Posts: 3
Joined: Wed Mar 08, 2017 3:54 pm

OpenVPN works for seconds only

Postby AllaPugna » Wed Mar 08, 2017 4:16 pm

On my system I have a double boot linux/windows, and a virtual machine with linux on the windows partition.
When I connect from the linux partition I can use openvpn correctly. When I use it on Windows or the Linux virtual machine, it works for some seconds and then stops.
No errors, no messages in the logs, it simply doesn't work, but everything seems ok:
the openVPN tray bar icon on windows keep showing the green color, and the wifi icon shows the connection as working. I'm using a VPN service (nordVPN) so it shouldn't be a problem of the .opvn file (I download that directly from them). This happen both with TCP and UDP.
Since it doesn't work also on the virtual machine I think it's some strange problem with windows.
If I check my ip with a geographic tool during the first seconds I can see that it's correctly connected to the vpn server. I can also surf during those seconds.
I'm on windows 10 x64 edu version, and I'm connecting throught the TAP-windows adapter V9. I'd like some help to debug this since the log gives no hints. This is the windows log:

Code: Select all

Tue Mar 07 12:43:04 2017 OpenVPN 2.4.0 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Jan 31 2017
Tue Mar 07 12:43:04 2017 Windows version 6.2 (Windows 8 or greater) 64bit
Tue Mar 07 12:43:04 2017 library versions: OpenSSL 1.0.2k  26 Jan 2017, LZO 2.09
Enter Management Password:
Tue Mar 07 12:43:04 2017 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Tue Mar 07 12:43:04 2017 Need hold release from management interface, waiting...
Tue Mar 07 12:43:05 2017 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Tue Mar 07 12:43:05 2017 MANAGEMENT: CMD 'state on'
Tue Mar 07 12:43:05 2017 MANAGEMENT: CMD 'log all on'
Tue Mar 07 12:43:05 2017 MANAGEMENT: CMD 'hold off'
Tue Mar 07 12:43:05 2017 MANAGEMENT: CMD 'hold release'
Tue Mar 07 12:43:06 2017 MANAGEMENT: CMD 'username "Auth" "my username"'
Tue Mar 07 12:43:06 2017 MANAGEMENT: CMD 'password [...]'
Tue Mar 07 12:43:06 2017 WARNING: --ping should normally be used with --ping-restart or --ping-exit
Tue Mar 07 12:43:06 2017 NOTE: --fast-io is disabled since we are running on Windows
Tue Mar 07 12:43:06 2017 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Mar 07 12:43:06 2017 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Mar 07 12:43:06 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]addresssss:443
Tue Mar 07 12:43:06 2017 Socket Buffers: R=[65536->65536] S=[65536->65536]
Tue Mar 07 12:43:06 2017 Attempting to establish TCP connection with [AF_INET]addresssss:443 [nonblock]
Tue Mar 07 12:43:06 2017 MANAGEMENT: >STATE:1488886986,TCP_CONNECT,,,,,,
Tue Mar 07 12:43:07 2017 TCP connection established with [AF_INET]addresssss:443
Tue Mar 07 12:43:07 2017 TCP_CLIENT link local: (not bound)
Tue Mar 07 12:43:07 2017 TCP_CLIENT link remote: [AF_INET]addresssss:443
Tue Mar 07 12:43:07 2017 MANAGEMENT: >STATE:1488886987,WAIT,,,,,,
Tue Mar 07 12:43:07 2017 MANAGEMENT: >STATE:1488886987,AUTH,,,,,,
Tue Mar 07 12:43:07 2017 TLS: Initial packet from [AF_INET]addresssss:443, sid=bb205781 4c0e1790
Tue Mar 07 12:43:07 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Tue Mar 07 12:43:07 2017 VERIFY OK: depth=1, C=PA, ST=PA, L=Panama, O=NordVPN, OU=NordVPN, CN=myVPN, name=myVPN, emailAddress=cert@myvpn.com
Tue Mar 07 12:43:07 2017 Validating certificate key usage
Tue Mar 07 12:43:07 2017 ++ Certificate has key usage  00a0, expects 00a0
Tue Mar 07 12:43:07 2017 VERIFY KU OK
Tue Mar 07 12:43:07 2017 Validating certificate extended key usage
Tue Mar 07 12:43:07 2017 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Tue Mar 07 12:43:07 2017 VERIFY EKU OK
Tue Mar 07 12:43:07 2017 VERIFY OK: depth=0, C=PA, ST=PA, L=Panama, O=myVPN, OU=myVPN, CN=it3.myVPN.com, name=myVPN, emailAddress=cert@myVPN.com
Tue Mar 07 12:43:07 2017 Control Channel: TLSv1.2, cipher TLSv1/SSLv3 ECDHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
Tue Mar 07 12:43:07 2017 [it3.nordvpn.com] Peer Connection Initiated with [AF_INET]addresssss:443
Tue Mar 07 12:43:08 2017 MANAGEMENT: >STATE:1488886988,GET_CONFIG,,,,,,
Tue Mar 07 12:43:08 2017 SENT CONTROL [it3.myvpn.com]: 'PUSH_REQUEST' (status=1)
Tue Mar 07 12:43:09 2017 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,sndbuf 524288,rcvbuf 524288,dhcp-option DNS 78.46.223.24,dhcp-option DNS 162.242.211.137,route-gateway 10.7.7.1,topology subnet,ping 60,ping-restart 180,ifconfig 10.7.7.5 255.255.255.0,peer-id 0,cipher AES-256-GCM'
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: timers and/or timeouts modified
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: --sndbuf/--rcvbuf options modified
Tue Mar 07 12:43:09 2017 Socket Buffers: R=[65536->524288] S=[65536->524288]
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: --ifconfig/up options modified
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: route options modified
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: route-related options modified
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: peer-id set
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: adjusting link_mtu to 1659
Tue Mar 07 12:43:09 2017 OPTIONS IMPORT: data channel crypto options modified
Tue Mar 07 12:43:09 2017 Data Channel Encrypt: Cipher 'AES-256-GCM' initialized with 256 bit key
Tue Mar 07 12:43:09 2017 Data Channel Decrypt: Cipher 'AES-256-GCM' initialized with 256 bit key
Tue Mar 07 12:43:09 2017 interactive service msg_channel=628
Tue Mar 07 12:43:09 2017 ROUTE_GATEWAY 10.5.24.254/255.255.255.0 I=18 HWADDR=macccc
Tue Mar 07 12:43:09 2017 open_tun
Tue Mar 07 12:43:09 2017 TAP-WIN32 device [Ethernet 2] opened: \\.\Global\{F621B7D4-774D-49DF-B669-EE83B063C5DF}.tap
Tue Mar 07 12:43:09 2017 TAP-Windows Driver Version 9.21
Tue Mar 07 12:43:09 2017 Set TAP-Windows TUN subnet mode network/local/netmask = 10.7.7.0/10.7.7.5/255.255.255.0 [SUCCEEDED]
Tue Mar 07 12:43:09 2017 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.7.7.5/255.255.255.0 on interface {F621B7D4-774D-49DF-B669-EE83B063C5DF} [DHCP-serv: 10.7.7.254, lease-time: 31536000]
Tue Mar 07 12:43:09 2017 Successful ARP Flush on interface [24] {F621B7D4-774D-49DF-B669-EE83B063C5DF}
Tue Mar 07 12:43:09 2017 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Tue Mar 07 12:43:09 2017 MANAGEMENT: >STATE:1488886989,ASSIGN_IP,,10.7.7.5,,,,
Tue Mar 07 12:43:14 2017 TEST ROUTES: 1/1 succeeded len=0 ret=1 a=0 u/d=up
Tue Mar 07 12:43:14 2017 C:\Windows\system32\route.exe ADD addresssss MASK 255.255.255.255 10.5.24.254
Tue Mar 07 12:43:14 2017 Route addition via service succeeded
Tue Mar 07 12:43:14 2017 C:\Windows\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.7.7.1
Tue Mar 07 12:43:14 2017 Route addition via service succeeded
Tue Mar 07 12:43:14 2017 C:\Windows\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.7.7.1
Tue Mar 07 12:43:14 2017 Route addition via service succeeded
Tue Mar 07 12:43:14 2017 Initialization Sequence Completed
Tue Mar 07 12:43:14 2017 MANAGEMENT: >STATE:1488886994,CONNECTED,SUCCESS,10.7.7.5,addresssss,443,10.5.24.73,52176

No lines are added until I disconnect

I think this is probably Windows related but if anyone could point me to the right direction I'd be very happy.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2089
Joined: Fri Jun 03, 2016 1:17 pm

Re: OpenVPN works for seconds only

Postby TinCanTech » Wed Mar 08, 2017 6:05 pm


AllaPugna
OpenVpn Newbie
Posts: 3
Joined: Wed Mar 08, 2017 3:54 pm

Re: OpenVPN works for seconds only

Postby AllaPugna » Wed Mar 08, 2017 7:48 pm

I've got the last community version of openvpn (2.4.0), the software GUI is openVPN GUI 11.4.0
The opvn files can be found here https://nordvpn.com/api/files/zip

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2089
Joined: Fri Jun 03, 2016 1:17 pm

Re: OpenVPN works for seconds only

Postby TinCanTech » Wed Mar 08, 2017 8:09 pm

This Forum does not support your VPN provider.

AllaPugna
OpenVpn Newbie
Posts: 3
Joined: Wed Mar 08, 2017 3:54 pm

Re: OpenVPN works for seconds only

Postby AllaPugna » Thu Mar 09, 2017 9:43 am

Thank for the answer, anyway the problem is not linked to my vpn provider (I'm 99% sure it's on the client side). I know this forum is more for another kind of problems but I'd like some pointers from you people since you probably have some steps to solve problems from the client side. I going to look for another opvn file from someone else so I can confirm that indeed it's not my vpn provider fault.


Return to “Off Topic, Related”

Who is online

Users browsing this forum: No registered users and 2 guests